Rtmedia Problem


#1

Hi rtmedia has problem to send text with media on activity wall. just send text.


#2

Hello @Amirhossein_Kofeiti,

Could you confirm if you get the same issue when any default theme of WordPress is enabled and other plugins disabled on your site?

Thank you.


#3

on that situation you said it’s ok i test on an other wp site. but in this site www.afrafa.com i have serious problem. i can access you or you can just simple register and test it.


#4

Hi there, I have encountered the same problem : I can post a text message on the activity wall, but not to attach a picture for example. The picture can be selected or dropped in the window and the thumbnail is shown if I click again in the message area, but after being posted, the message only contains the text. However, I know that it works with the same Rtmedia version on my test website. It’s only on my production website where it doesn’t work. See below the debug informations for both websites.

For information, the picture to attach is a 74 KB only Jpeg. Thanks.

Production site :

Home URL	http://www.site-des-jobert.org
Site URL	http://www.site-des-jobert.org
PHP	5.5.9-1ubuntu4.5
MYSQL	5.5.40
WordPress	4.5.2
BuddyPress	2.5.2
rtMedia	3.10.6
OS	Linux
Imagick	Not Installed
GD	2.1.1-dev
[php.ini] post_max_size	8M
[php.ini] upload_max_filesize	2M
[php.ini] memory_limit	256M
Installed Plugins	rtMedia for WordPress, BuddyPress and bbPress par rtCamp version 3.10.6, 
BuddyPress Members only par Tomas Zhu version 1.1.0, 
BuddyPress par La communauté BuddyPress version 2.5.2
Theme Name	Sunspot
Theme Version	1.1.4
Author URL	https://wordpress.com/themes/
Template Overrides	plugins/buddypress-media/templates/media/album-gallery-item.php, 
plugins/buddypress-media/templates/media/album-gallery.php, 
plugins/buddypress-media/templates/media/album-single-edit.php, 
plugins/buddypress-media/templates/media/media-gallery-item.php, 
plugins/buddypress-media/templates/media/media-gallery.php, 
plugins/buddypress-media/templates/media/media-single-edit.php, 
plugins/buddypress-media/templates/media/media-single.php, 
plugins/buddypress-media/templates/media/uploader.php
Total Albums	1
Total Photos	1

Test website :

Home URL	http://localhost
Site URL	http://localhost
PHP	5.6.10
MYSQL	5.5.42
WordPress	4.5.2
BuddyPress	2.5.2
rtMedia	3.10.6
OS	Darwin
Imagick	Not Installed
GD	bundled (2.1.0 compatible)
[php.ini] post_max_size	32M
[php.ini] upload_max_filesize	32M
[php.ini] memory_limit	256M
Installed Plugins	BuddyPress Default Data par slaFFik version 1.1, 
rtMedia for WordPress, BuddyPress and bbPress par rtCamp version 3.10.6, 
BuddyPress Members only par Tomas Zhu version 1.1.0, 
BuddyPress par La communauté BuddyPress version 2.5.2
Theme Name	Sunspot
Theme Version	1.1.4
Author URL	https://wordpress.com/themes/
Template Overrides	plugins/buddypress-media/templates/media/album-gallery-item.php, 
plugins/buddypress-media/templates/media/album-gallery.php, 
plugins/buddypress-media/templates/media/album-single-edit.php, 
plugins/buddypress-media/templates/media/media-gallery-item.php, 
plugins/buddypress-media/templates/media/media-gallery.php, 
plugins/buddypress-media/templates/media/media-single-edit.php, 
plugins/buddypress-media/templates/media/media-single.php, 
plugins/buddypress-media/templates/media/uploader.php
Total Albums	1
Total Photos	2

Thank you for your help !


#5

Hi there,

I have made another test of uploading a small picture file in the activity flow, and had a look at the Firefox web developper console. I can see the following error in the console, after posting the note (including the picture that does not show) :

POST http://www.site-des-jobert.org/activity/upload/ => HTTP/1.1 404 Not Found.

That’s why it is not able to upload the file onto the website. Is there’s a apache rewrite issue ? Otherwise everything works fine.

I made a “chmod -R 770” on all directories/files to be sure it is not a permission issue.

Thanks for helping me if you can.


#6

Hi there,

It seams that the 3.10.7 rtmedia update fixed the issue. The pictures are now posted properly in the activity feed after validating the post. I encourage you to update rtmedia with this version. I was desesperate to find out how to solve this problem. I have disabled the “direct upload” option on my production website cause it was disabled also on my test website, but I’m not sure at all it has some influence on the problem. Have a nice day.


#7