rtMedia commandeers /media url


#1

I currently use an older version of BuddyPress (1.7.2) and an older version of BuddyPress Media (2.13.2). I’ve cloned my site to a dev server and have upgraded everything to the latest versions of BuddyPress and the new rtMedia. On my site, I have a page at example.com/media and several child pages such as /media/live. When I upgrade to the latest version of rtMedia, it commandeers the example.com/media URL to go to a user’s profile meida page. I’ve tried disabling the media in profiles (which I’d rather not do) but it still doesn’t fix the URL issue. Is there a way to change the URL used by rtMedia? I really don’t want to change my media pages to a different URL as it would break links all over the place.


#2

@ethanthekiwi, Yeah, /media (Default media slug) is getting handled by rtMedia that's what causing the issue. You can change default media slug. Check this document for defined constants -> https://rtcamp.com/rtmedia/docs/developer/rtmedia-defined-constants/ and modify 'RTMEDIA_MEDIA_SLUG' to any other slug you want ex. portfolio.


#3

Thanks that is what I am looking for. I changed added the line of code to wp-config and changed the media slug from "media" to "rtmedia" but now none of the media links are working in Buddypress profiles at http://example.com/members/username/rtmedia/. Going to that url returns "Sorry, no content matched your criteria." Going to http://example.com/members/username/media/ returns a 404 error. Are there other settings or some kind of rebuild that I need to do?


#4

Try re-saving permalinks.


#5

I changed my permalinks, saved, changed them back and saved again. It's still giving me the same error. Am I correct in thinking that I only need to change one line of code in wp-config that changes the slug. I don't need to change the Media Label or any of the other ones?


#6

Yes, you just need to change RTMEDIA_MEDIA_SLUG in wp-config.php file. define ( 'RTMEDIA_MEDIA_SLUG', 'your_media_slug_here' )

After this save your permalinks.

I just tried on my end and is working perfectly fine.


#7

Ok, thanks for your help. I'll play with it and get it working.


#8