rtMedia 3.10.5 uploaded images do not show in activity feed


#1

I’m using Buddypress 2.4.3 with rtMedia. Everytime I try to upload images via button, I don’t see the images in activity feed. There’s no error occurred in either the ajax calls or js.

Moreover, the images I uploaded don’t appear in my profile photo albums, even if I turn on the follwing options:

This ajax call after image upload returns me html that has 0 image in <ul class="rtmedia-list rtm-activity-media-list rtmedia-activity-media-length-0"></ul>:

POST http://localhost/website/wp-admin/admin-ajax.php

action:post_update
cookie:bp-activity-oldestpage%3D1
_wpnonce_post_update:25c5ff5fd4
content:&nbsp;
object:
since:0
_bp_as_nonce:
rtMedia_attached_files[]:0
rtMedia_attached_files[]:0
rtMedia_attached_files[]:0
rtMedia_attached_files[]:0
rtmedia-privacy:undefined

Does this have something to do with privacy? Here’s my privacy settings:


#2

Hi John,

We have checked the issue using BuddyPress 2.4.3 and also with the latest version 2.5.2. However, with both the versions the feature is working fine for us. It seems that the issue persists at your end. I would suggest you to check this issue by using WordPress default theme and deactivating other plugins. Let us know if the issue still persists.

Thank you.


#3

Hi @ArchanaSolanki It was some issues with my database All good now. thanks!


#4

So how did you solve your problem, i seem to be going through something similar


#5

Hi Charles, Not sure if we have the same issue. But here’s how I fixed it: I grant my database user all privileges from cPanel and it worked fine. Hope it helps.


#6