Rt-fastcgi-cache shows a miss on woocommerce product pages


#1

So I can see that EasyEngine has some rules in place for Woocommerce

And I can understand why as you don’t want someone to see their cart is empty when they add something to do it.


However, I have a couple of Woocommerce websites that are external links only. This has led to the rt-fastcgi-cache flag in Chrome’s console to show as a miss on any product page. It shows a hit (meaning it works) on the front page. . .but it’s a complete miss on the product pages.

Is there a way that I can get around this? Again, I want the site to cache the woocommerce pages just like they would any other WordPress post. There isn’t an ‘add to cart’ button for them to use as it’s all using the External Product version of a product.

If anyone has any pointers, then I would greatly appreciate it.


#2

You can see this in action on both PlayStoreSales.com as well as AppStoreApps.com


#3

for those curious, I added

set $skip_cache 0;

to my /etc/nginx/sites-available/domain.com file and after a restart of nginx things seem to be caching properly


#4

Well, I had thought that worked. . .but now that I have checked the site this morning, I’m getting multiple misses even when going back and forth from the front page to the product page :frowning:

How can I fix this?


#5

hrmm, so something ended up breaking it overnight because I just rebooted the VPS instance and now it’s showing them as HITs again (meaning it’s caching them properly

I don’t get what would have caused this to break. I have swap setup (which is barely used (I typically sit on 300-700MB out of 2GB of RAM). it was over night, so there only spikes in the graphs are when updraft did its backup

If anyone has an idea (or maybe this was just a hiccup and it won’t happen again). let me know. I would really love to find a way to setup an alert that would tell me when this happens so I know when I need to reboot the VPS instance again


#6

Just did another test. This is 9 hours after be restarting the VPS instance this morning.

All of these tests have been done in Chrome’s Incognito Mode (to prevent things like the bypass message) I pulled up the console, clicked the network tab, clicked a product page, MISS. Clicked the logo to go back to the home screen, MISS Clicked the same product page, MISS Clicked the logo to go back to the home screen again, MISS


I just don’t get what is going on here. Should I not be using FastCGI when using WooCommerce? Should I not use the suggested memcached options for objects and databases when using WooCommerce?

Should I setup the NGINX site with super cache? redis cache? Would it be better to set it up with no cache at all and let something like WP Rocket handle the cache?

I am really at a loss here and need to figure this out


#7

Not sure how to resolve this. But have you tried using Swift Performance lite? Try using redis. Simple Cache also has an option to specify which cache to use. ie Mem or Redis. Simple cache was delivering hits on one of my woo sites.


#9

I have not. But do you think I should delete the Redis plugin that EE installs when I switch over to it (I don’t want to cause any conflicts).

Or should it stay installed when I test the Simple/Swift Performance cache plugins?


#10

Remove Redis plugin. I know I used the redis plugin with object cache it stuffed up everything.

Simple cache is very stable and works well too!


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.