Roksprocket


#1

First off. Love easyengine! Thank you for this awesome tool.

I hate to ask this question here but I’ve exhausted all other resources. And I’ve searched everywhere but can’t find any help.

I’m migrating my wordpress site from an apache server to the ee nginx stack. And one of the plug-ins I used on my apache server was roksprocket.
http://www.rockettheme.com/wordpress/plugins/roksprocket

When I install roksprocket on a fresh install of the ee nginx stack the plug-in refuses to work. When I hit any save button nothing at all happens.

When I install roksprocket on a fresh apache server… no issues.

I have a feeling that something is missing in the ee nginx stack stopping this plug-in from working.

I really don’t want to go back to apache.

Any thoughts?


#2

I believe it has something to do with XMLHttpRequest


#3

Looking further into it I believe there is something missing from the nginx.conf causing improper responses:

  
Remote Address:example.com:80  
Request URL:http://example.com/wp-admin/admin-ajax.php?action=roksprocket&nonce=4e79d82c02  
Request Method:POST  
Status Code:200 OK  

Request Headers  
Accept:text/javascript, text/html, application/xml, text/xml, */*  
Accept-Encoding:gzip,deflate,sdch  
Accept-Language:en-US,en;q=0.8,es;q=0.6  
Connection:keep-alive  
Content-Length:158  
Content-type:application/x-www-form-urlencoded; charset=UTF-8  
Cookie:wordpress_8d5c55f263f1fbeaeacab59de0ed539f=webmaster%7C1399299571%7Cc45cc66c20278417596ac7a86a44f14c; gantry-android-switcher=1; PHPSESSID=lc8g3abuip5geje0mfq9c2m0v2; wp-settings-time-1=1399126752; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_8d5c55f263f1fbeaeacab59de0ed539f=webmaster%7C1399299571%7C9762057a27f2113db6f91e2435df4d87; roksprocket-showitems=1; gantry-android-switcher=1; wp-settings-time-3=1399174698  
Host:example.com  
Origin:http://example.com  
Referer:http://example.com/wp-admin/admin.php?page=roksprocket-edit&nonce=4e79d82c02&paged=1&id=0  
User-Agent:Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.131 Safari/537.36  
X-Requested-With:XMLHttpRequest  

Query String Parameters  
action:roksprocket  
nonce:4e79d82c02  

Form Data  
id:0  
uuid:eb62825b-8b2c-4251-cd0b-ddcfabf45c5c  
title:test  
params[provider]:wordpress  
params[layout]:tabs  
task:  
model:edit  
model_action:save  
model_encoding:form  

Response Headers  
Access-Control-Allow-Credentials:true  
Access-Control-Allow-Headers:Content-Type, Authorization, X-Requested-With  
Access-Control-Allow-Methods:GET, PUT, POST, DELETE, OPTIONS  
Access-Control-Allow-Origin:localhost  
Access-Control-Allow-Origin:http://example.com  
Cache-Control:no-cache, must-revalidate, max-age=0  
Content-Encoding:gzip  
Content-Type:text/html; charset=UTF-8  
Date:Sun, 04 May 2014 03:38:37 GMT  
Expires:Wed, 11 Jan 1984 05:00:00 GMT  
Pragma:no-cache  
Server:nginx  
Transfer-Encoding:chunked  
Vary:Accept-Encoding  
X-Content-Type-Options:nosniff  
X-Frame-Options:SAMEORIGIN  
X-Robots-Tag:noindex  

#4

Are you using mixture of HTTP or HTTPS site?

Or cross-domain ajax?

EasyEngine supports normal admin-ajax requests as it should.


#5

Using HTTP and not cross-domain


#6

Sorry to say we do not have enough info to debug issue.

You can check with plugin developer to see if they have any apache/webserver specific dependency.


#7