Response Headers 404 - favicon.ico


#1

Hello, I installed EasyEngine (WordPress with Redis cache) on AWS server.

When I run a speed test, there is favicon.ico file loading at the end with 404.

How can I remove this favicon.ico request?

Speed test result: https://tools.pingdom.com/#59b014e443800000

Thank you :slight_smile:


#2

It is not EE related. It is WordPress related. To resolve this “issue” you should head to your homepage and in the upper left corner click “Customize” > Site Identity > Site Icon.
When you setup the site icon you will have no problems.

That worked for me, you can try it too.

Cheers


#3

I have added favicon using WordPress Customizer but it is not loading :frowning:

I have cleared all cache and restarted the services.

image


#4

the site icon should be 512x512px minimum Try to do it with default WordPress theme and without plugins. If it is working then there is something wrong with the theme you are using or with plugins. Cheers


#5

Something wrong with the server config.


#6

It’s not really WordPress related - web browsers look for it, amongst other things it’s what creates that little image at the top of your web browser tabs (next to the page title). So it’s just an icon image file. If you don’t care about the image showing up, then just ignore the 404 error - you can’t stop browsers trying to find it, and it isn’t slowing your site down.

But if you want the image to show up, then follow what bredpit said (you maybe didn’t use a large enough image).


#7

I can assure you that it has nothing to do with the EE unless you did something. If you do not want to add a site icon then just put an empty (transparent) 512x512 png file. This will put no impact on your site.

If it is not working, then test it on a clean server with fresh wp installation with default theme.


#8

Hey, what I meant here is that if he is using wp (and he is) then he can fix it by adding a site icon via wp and resolve the issue. EE has nothing to do with it. I usually try to avoid any errors, and having one (even if its not important) is a pain to look at :slight_smile:
It’s an easy fix.