Repo Key Expired Error for EasyEngine on Ubuntu 16.04


#1

after running sudo apt update

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/xUbuntu_16.04  Release: The following signatures were invalid: KEYEXPIRED 1501595774
W: Failed to fetch http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/xUbuntu_16.04/Release.gpg  The following signatures were invalid: KEYEXPIRED 1501595774

How can I download the correct key?


#2

I can confirm this. It does not just affect Ubuntu 16.04. Both 14.04 and 16.04 servers are affected. This is because the repo key has expired. Hopefully the EE guys will update it. If you really must do an upgrade: sudo apt-get --allow-unauthenticated upgrade

This is dangerous though


#3

Also confirmed - I have the same expired key error. Also hoping for an updated key soon!


#4

I also get the error. I guess everyone who uses this repo will get the error.

Must be related to this issue on Github:


Multiple errors when updating ubuntu 16.04
#5

The expiry date for the key has been extended. You can update it on existing installations using sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03

Users installing EasyEngine on a fresh VPS will not have to do anything extra. The updated key will automatically be used.


#6

Doesn’t work, I get the following message after executing

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.pjTVvDuAOK --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/chris-lea-redis-server.gpg --keyring /etc/apt/trusted.gpg.d/ondrej-php.gpg --keyring /etc/apt/trusted.gpg.d/ondrej-php5-5_6.gpg --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03
gpg: requesting key D2AE6F03 from hkp server keyserver.ubuntu.com
?: keyserver.ubuntu.com: Connection refused
gpgkeys: HTTP fetch error 7: couldn't connect: Connection refused
gpg: no valid OpenPGP data found.

#7

Thanks @mriyam.tamuli worked for me


The repository 'http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/xUbuntu_16.04 Release' does not have a Release file
#8

Check if your port 11371 is not blocked in your firewall.


#9

Has anyone solved this problem?


#10

Yes I have by executing the above command. Make sure that the time on your server is correct. I always make it a habit of connecting my server to ntp and adjusting the timezones


Ee stack install failed
#11

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03

…worked for me.


#12

Still having this issue on Oct 14, with all of the above solutions not fixing it. Any ideas?


#13

Are you sure your issue is related to keys, @yazeed?


#14

I’m getting the exact same error above.


#15

There is an outage on Upen Suse repo, affecting all EE users.

Take a look at recently updated threads.


closed #16