Redisearch Module

Hi ee users,

I have a website with 40k posts. I wanted to install Redisearch Plugin (

I installed the redisearch via docker from here (

After running the redisearch, I set up the plugin with this info:
Redis server: redis
Port: 6379

Error shows: RediSearch module not loaded!

Then I tried to get the redisearch IP by using this command
docker inspect festive_wu | grep IPAddress

I changed the Redis Server from redis to the IP Address from the container but new error shows:
Something went wrong while conencting to Redis Server! So I changed the Redis server to ‘redis’

How do I make redisearch module to load to be able to completely setup the plugin.

@kirtan @mrrobot47

Hi seyntjim,
I am not sure whether you still need this information one year later or not, but I have managed to install Redisearch on a server with easyengine.
You need to run the redis container in docker, then add it to the network of the site you want to use it with (at least that’s the way it worked for me…)
Here are the steps I did:

docker run -d --name redisearch_container --restart=unless-stopped -p 6379:6379 redislabs/redisearch:latest

then add it to the network of your site.
you can use docker network ls to view the networks.
Then use docker network connect NAME_OF_NETWORK redisearch_container

Now you should be able to connect to the redisearch container from the wordpress site with the following options:
Redis server: redisearch_container
Redis port: 6379
Redisearch index name: can be whatever name you want

Hope this helps anyone who is trying to setup redisearch, took me quite a while to figure it out eventually