Redirection uncessfull : erreur 404

Hi !

I migrated my blog to wordpress, I have followed your instructions but I have a problem with the last step with the extension " Blogger to Wordpress Redirection ".

I copied template code generated below and paste them in my template but the test is unsuccessfully (error 404)

Clicking this link » http://ohlovelyplace.blogspot.com
Should redirect to »

Before this manipulation, my articles to blogger were already redirected towards my wordpress. (Doubtless thanks to a previous stage of your tuto no ? I follow this : But when I look at my Google webmaster tools I have a lot of untraceable pages (error 404). I am lost, I don’t know what to do…

I tried to delete an article of my blogspot to see if it had an incidence on the display of the same article on my wordpress, and there seems not be it: the article always displays on my wordpress.

Can you help me please?
And please, excuse me for my bad English !


Camille -

Hello Camille,

  1. This is not a correct URL of post
>>> Clicking this link » http://ohlovelyplace.blogspot.com

It won't get redirect towards WordPress post.

  1. If you see this cache page of your old blogger post (click on any of the post), it redirect towards WordPress posts (if that post/article is present in WordPress). As you said most of the posts are deleted by you from blogger blog, so that respective blogger post will not redirect.

Thank you for your answer :)

But I don't understand well :

I tested the mask of my old blogger, indeed that redirects well towards the same article on wordpress.

But for the untraceable pages of my tool Google Webmaster, I don't understand: I just deleted two articles of my blogger to see if they always went display on my wordpress (it's ok) but I have all the same almost 110 errors 404... Thus a big problem of rerouting, no?

This last step of your tuto of migration (with the test of addresses) normally has to solve this problem that's it? Why it is not the case?

Thank you for your answers, I shall like so much that it works!

  1. Make sure the fix.php file from our DIY article worked for you. If yes, then all the old blogpost URLs should be working redirecting fine.
  2. Submit the sitemap of your new WordPress blog to Google Webmaster tool.
  3. Disable google search under privacy in your account.
  4. Wait for few days, I hope Google will crawl the links again.

Thanks, --Nitun

Thanks :)

Yes the fix file worked for me, and I submit the sitemap on my new Wordpress blog to Google webmaster tool (Yesterday when I saw all these errors 404).

Concerning the step 3 "Disable google search under privacy in your account. " : It's at the level of the part " Confidentiality : Listed to Blog. Visible by search engines. " That I have to modify, something ? The choice is:

to add your blog to our lists? Yes / No Let search engines find your blog? Yes / No (If yes that I do have to select?)

Or, it's at the levet of the part " Readers of the blog" that i have to modify something ? The choice is :

Public (blog open to all the readers) Private - Access reserved only for the authors of the blog Private - Access reserved for certain readers with password (If yes that I do have to select?)

Unless it is in both parts ? I made two impressions of screens of these parts, if it can help you to place them to blogger.

Other remark: by analyzing my errors 404 I reports me that it is about urls with at the end: ""

By deleting it "? M=1 " at the end of the url, the rerouting works. But with, the url sends back on one page not found on my wordpress.Do you think that the fact of putting my blogger in private will solve this problem? Do you know what mean "? M=1 "?

Thank you infinitely for your answers!

Attachment Link(s):’écran-2014-03-07-à-10.43.27.png’écran-2014-03-07-à-10.43.43.png

Go with this one:

to add your blog to our lists? Yes / No Let search engines find your blog? Yes / No (If yes that I do have to select?)

Regarding ?m=1“: Its because your blogger blog added extra parameter in URL for mobile devices. You need to disable it from blogger settings. Refer this And also you can try by adding some .htaccess rule in WordPress for such URL redirection: RewriteCond %{QUERY_STRING} ^m=1$ RewriteRule (.*) $1? [R=permanent]

right after the RewriteEngine On RewriteBase / line, I hope it will help you.


Thanks !

I added the code in my file .htaccess :

`# BEGIN WordPress RewriteEngine On RewriteBase / RewriteCond %{QUERY_STRING} ^m=1$ RewriteRule (.*) $1? [R=permanent] RewriteRule ^index.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

END WordPress`

Because for the first method, I have no more access to the mobile version of my blogger with the classic template.I am going to wait a little and test the functioning of this second method.

Thank you very much!

Because for the first method, I have no more access to the mobile version of my blogger with the classic template.

As you moved from blogger to WordPress, you don't even need access of mobile version of blogger blog.