Redirection to Homepage

Hi There,

I’ve just installed this plugin to redirect posts from to My new wordpress website is hosted on GoDaddy.

All the posts are redirecting, but they are not redirecting to the respective post, they are redirecting to the Homepage. I’ve looked at the other support threads from other users who have had this problem, but I can’t seem to find a definitive answer. I rang GoDaddy to ask if it was a restriction on their server, and they said it wasn’t.

Clicking on this link:

… Takes me to this address:

… Which is the homepage of my website:

Any suggestions on what I need to do? Please note that my new website is in pre-launch mode at the moment, so if you try the above then you will be presented with a pre-launch page. However I have tried without the pre-launch page, and it is still going to the Homepage.



hi @everythingtheatre,

Please check below mentioned things :

  1. Make sure Blogger-to-WordPress Plugin is always activated.

  2. Please crosscheck you have added correct script code to the blogger template generated by our Blogger to WordPress plugin.

  3. Check in custom fields [blogger_permalink] field under imported posts is mapped with same blogger URL.

You can refer to this support question for more information.


I spoke to GoDaddy again - they said that they will not disable mod_security, but they can whitelist IP addresses - what would I need to whitelist in order to make this work?



It’s strange, we never faced this kind of redirection issue with GoDaddy, may be they have made some changes in there mod_security rules recently.

Please crosscheck the points which I mentioned in earlier reply.

If the problem still persists, then I would suggest you to switch to another hosting account.

Hi there, it has now started working so thank you very much!

One more question - is there any way to redirect specific blogger URLs to specific wordpress URLs?

For example, I had an old blogger page:

I would like that URL to redirect to this wordpress category archive:

Is there a way to do this?



Hi @everythingtheatre,

Seems like you already solved the issue, please let us know if you have any other queries.

Happy New Year!!! :slight_smile: