Redirection not working issue?

I have looked through previous topics and have:

  • ensured plugin is activated
  • switched off mod_access server side
  • changed permalink structure

Yet old blogger posts redirect to homepage with a strange url. When I test set up and click this url:

it redirects to Is there an issue with the url being when the main setting for the blog are

Please help!


Can you please cross check if code generated by blogger to WordPress redirection plugin added correctly in template? It seems like the cause.

I had originally moved it to a classic template so switched it back. When I edit the HTML am I pasting over the entire existing code or just a part of it. It is unclear from the screenshot on the instruction page how I need to correctly add the html. Can you clarify?

Right now I am unsure how to crosscheck if I have added correctly.


I hope this video will helpful

That is exactly the process I have followed and all I get is urls with b2w= in such as: And am redirected to the homepage.

Any other suggestions?

Hello @ssweet

Check this old topic discussion Redirecting to Index, there mentioned about blogger_permalink and blogger_blog custom fields, please cross check if proper values are imported under those fields.

Unfortunately I have already spent the last two days checking previous posts on similar topic and have cross checked everything which is why I am sending the support email.

Is anyone actually able to look at the blog in question?

Are there any plugins that are not compatible with yours that might be causing an issue?

No, it should not conflict with any other plugin. Never heard or face such question in past.

Can you please edit one post in WordPress dashboard which is imported from and check if custom fields name blogger_blog and blogger_permalinks values.

Lets check for this post " a-little-look-at-little-wood-2-hall" edit it and check if blogger_permalink is present with value “a-little-look-at-little-wood-2-hall.html” or something like this.

Also, I found that, this URL is not found. and after cross checking, found this URL

It seems like the post slugs not updated after importing content. That could be a reason posts are redirecting towards home page.

Please run fix.php file which mentioned in this article



I ran the fix.php and reached the DONE screen. Redirection is still not working.


It seems something wrong there. You have blogger_blog value , but the redirection is taking place from URL, I think it was your old blogger blog URL.

This might be happened when you have imported content using url and after that changed URL in to URL. Hence values saved in that way.

Now, it could be a try and error process. You can try to replace that custom value for that single post only from to and then try the redirection again. If that works, do the same for all the other imported posts (using custom sql query).

Or, if still problem persist, you may consider to hire some professional to provide complete blogger to WordPress migration. or get in touch with our team



This was the issue I mentioned in my very first email.

My account settings in blogger are : However Google assigns depending on the country you are in (see here: . So this isn’t taken account of in your plugin?

Yes, I know in first reply you mentioned that. However, it will not affect the plugin generated code because of country wise URL changes. As its not depend on from which blog URL the content has been fetched.

Again I have tested the same by importing one of my test blog, and it generated correct URL instead of (for India).

Hence, I suggested to cross check by changing value in custom field for single post.


I did that and it did not work