Redirection gets 404


#1

I believe I have followed all the direction in the video tutorial. The fix.php worked and the htaccess is changed. Permalinks flushed and set to the tutorial recommendation - /%year%/%monthnum%/%postname%.html.

However the redirection is generating a 404. example: When i want to go to this blogpost: http://waldentours.blogspot.ca/2016/03/14aug16-desert-adventures.html

I am redirected here: http://www.waldentours.com/?b2w=http://waldentours.blogspot.ca/2016/03/14aug16-desert-adventures.html

Also when I click on the verification button in the plugin, every test case is always: Clicking this link ยป http://waldentours.blogspot.com even when clicked on repeatedly. Never a blog title.

Any help is greatly appreciated. Thanks!


#2

Since posting this, the issue has been resolved. Here is the scenario:

  1. My host was Host Gator and upon reading on the numerous posts about Host Gator issues with security rules -ie - https://bloggertowp.org/tutorials/solved-blogger-to-wordpress-redirection-issue-with-hostgators-hosting/ I contacted Host Gator and they did remove the rule and whitelisted 1234234 on my account. That did resolve the 404 issues (after refreshing Permalinks several times).

  2. However I still had a second issue of the blog redirecting only to the Home Page. Others have noted this too and had it corrected through the security rules being corrected. Mine was not resolved with the security issues but turned out to be missing key custom meta data. The default Blogger importer did not bring in all the custom fields data - found under the hidden screen options within each blog post - as discussed here - All Blogger post redirect to the home page

I used an alternate importer plug mentioned on here somewhere - Blogger Importer Extended, Version 1.3, By Yuri Farina. This did the trick for me by importing way more info in the custom fields and I recommend it to anyone having the issue of posts all directing to the home page. Thanks to all the posts on this forum my blog is redirecting nicely now.


#3