Purge Entire Cache ends in “502 Bad Gateway”


#1

This is a post to note down my problem and solution to help anyone having the same trouble.

If you have following error in var/log/ngnix/domain.com.error.log

upstream sent too big header while reading response header from upstream, client: xxx.xxx.xxx.xxx, server: domain.com, request: "GET /wp-admin/options-general.php?page=nginx&nginx_helper_action=purge&nginx_helper_urls=all&_wpnonce=xxxx HTTP/2.0", upstream: "fastcgi://127.0.0.1:9070", host: "www.domain.com", referrer: "https://www.domain.com/wp-admin/options-general.php?page=nginx"

In my case, this is caused by Query Monitor plugin that I have activated.

Solution: Deactivate it and now problem solved.


#2