Purge Cache - Does not purge the cache


#1

Hi there,

I have an issue with Easy Engine, I run a site with 3 languages (using WPML) and wanted to add a 4th language, but after replicating the frontpage - And changing labels and headlines, the page kept showing the original page.

I then tried using the Purge Cache (at the top) - But that did nothing, and I found out that I needed to go to the Settings > Redis page and click the Flush Cache.

Screenshot from Redis page:

Screenshot from Nginx page:

I then created a new server instance (all are running in Amazon Web Services) and created a new site using the following command: sudo ee site create testblog.example.com --wpredis

And when looking at the Redis page:

The Status is disabled, and the Key Prefix (not shown on other installation) is the hostname of the server.

Is the original installation faulty?


#2

Hello,

For the key prefix, you have to add the following line in your wp-config.php file :

define( 'WP_CACHE_KEY_SALT', 'yoursitename:' );

On a clean install, EE never enable redis-object-cache by default.


#3

I will try to add this to my wp-config


#4

Should the Nginx prefix match the WP_Cache_Key_Salt?


#5

No, WP_CACHE_KEY_SALT should not be the same than the Nginx-helper prefix to purge cache.


#6

Did someone find a fix for this as it still not purging while all setting are in order?


#7