Purge all cache with W3 total cache results in a server 500 error


#1

Hi all,

When I try to purge all cache through the w3 total cache plugin, my wordpress site gives me a server 500 error …

Anyone knows why and how to solve this ?

Thanks in advance,

Lex


#2

Same thing no support or blog post i dont know what im doing wrong And if i want to fix via cmd it simply Say’s permission denied It just fresh install and no plugin instal only nginx helper and w3c for memcache

And accessing from ftp is headache too many folder and ram usage is very high Im going to do it myself rather than an automatic script


#3

Guys, please do some searches on official Plugin forums before posting here. This is an issue with W3TC not with EasyEngine.

Here is the solution:

Open the following file: /www/wp-content/w3tc-config/master.php

Search for cdnfsd.enabled

And replace 1 with 0 like below:

“cdnfsd.enabled”: “0”,


#4

Thanks for the reply Chopra … I will try it when I get the time … However , I did do many Google searches … did not come across a solution, except some posts that didn’t work for me … in any case thanks again and I will post if it worked or not …

Lex


#5

Just checked it … cdnfsd.enabled is allready set to ‘false’ … which is probably ‘0’ … so nothing different here …


#6

Try to remove W3TC, install it again, set cdnfsd.enabled to ‘false’ and then check if purge all works.


#7

So … in theory you are right … setting the cdnfsd to ‘0’ does work. However every time that I change another setting in w3tc through the admin, it will reset it back to ‘1’ … hence the cause of my problems.

So yes, setting it to 0 does work, after that an nginx restart is required… however it’s always going back to being set to ‘1’ when a setting is changed.

Any idea how to overcome this annoying thing ?


#8

How about configuring all the options first and then in last, change it to 0 as Cache Plugins don’t require any changes in configuration on the regular basis. I found no permanent solution other than that. Plugin Owners are aware of this issue and it will be fixed in the next update which has no confirmed date though.


#9

Yes, I came to that conclusion as well… it’s just a little bit of a pain when testing for performance increase (switching some settings around) … All in the game I guess…


#10