Problems with mail server


#1

Hi guys,

I’ve been trying to install a mail server and use it with my domain but I can’t find a way to connect to roundcube.

I used the “ee stack --mail” command and it installed everything.

I even connected to vimbadmin and created an email address with my domain

But I don’t know how to configure my dns to access to webmail.mydomain.com

My domain is with OVH and for now I have an A record pointing to the IP address of my server.

My host name is mydomain.com

What do i need to do to have access to the email address I just created and roundube at webmail.mydomain.com

Thanks in advance


#2

You can find all informations here : https://easyengine.io/tutorials/mail/fqdn-reverse-dns-ptr-mx-record-checks/


#3

I tried already to follow these steps but my A record is just the ip address of my server. If I change it to mail.domain.com I can’t access my website


#4

You can add more than a single A record


#5

Oh I didn’t know that.

So should I add a A record of mail.mydomain.com targeting the IP address ?


#6

Yes a A record to mail.yourdomain.tld a MX records to mail.yourdomain.tld etc …


#7

Ok thank you very much for the precisions. I’m quite a newbie in all DNS related configurations.

Now that I have all dns records set up, how exactly do I access Roundcube ?

Is it mail.mydomain.ltd ?


#8

#9

I tried that too. Actually it’s the first documentation I tried but it doesn’t work. Webmail.mydomain.com doesn’t work


#10

have you added a A records for webmail.yourdomain.tld ?


#11

Yes


#12

I have tried on a vps with Ubuntu 16.04 LTS, with two domains, and for both of them webmail.mydomain.tld redirect me to the webmail


#13

I must have have forget one step.

Can you please give me step by step what you did to get it ?


#14

Exactly the same step than in the section mail of the documentation :


#15

Ok my bad, there were a mistake with my mx record.

Now I can access it by webmail.domain.com

However when i try to connect to the email I created with vim admin it doesn’t work, the website says page is not accessible


#16

Have you created an admin account with the security salt code ? Try to remove and to reinstall the mail server :

ee stack purge mail
ee stack install mail

#17

Yeah I tried to install everything again and same problem.

I have access to the login panel, but when I try to login and press enter the website redirects to a page that is not present on the server.


#18

what is the error message displayed by your web browser ?


#19

It’s a browser error saying the page requested doesn’t exist


#20

Also on a different matter I cannot make my website work by forcing the www. Before my domain

I put a dns A record domain.com target IP address An other A record www.domain.com target IP address

And I put in the nginx conf of website the code from easy engine documentation to force www.

And now I have a browser error saying too many redirects…

I always have errors, what can I do ?