Problem with W3TC


#1

I’m getting this error from w3tc. W3 Total Cache error: It appears Page Cache URL rewriting is not working. Please verify that all configuration files are included in the configuration file (and that you have reloaded / restarted nginx). Unfortunately disk enhanced page caching will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server. Technical info nginx configuration file contains rules to rewrite url https://www.ryansmithphotography.com/w3tc_rewrite_test into https://www.ryansmithphotography.com/?w3tc_rewrite_test which, if handled by plugin, return “OK” message. The plugin made a request to https://www.ryansmithphotography.com/w3tc_rewrite_test but received: 404 Not Found instead of “OK” response.

I’m using https on my website so I’m wondering if something needs to be configured differently. For example in w3tc there is a checkbox to cache ssl requests, does the default easyengine w3tc.conf need to be altered to cache ssl. Here is my site configuration.

listen 443 ssl spdy;
server_name ryansmithphotography.com   www.ryansmithphotography.com;
ssl on;
ssl_certificate /var/www/ryansmithphotography.com/cert/ryansmithphotography.com.crt;
ssl_certificate_key /var/www/ryansmithphotography.com/cert/ryansmithphotography.com.key;

access_log /var/log/nginx/ryansmithphotography.com.access.log rt_cache;
error_log /var/log/nginx/ryansmithphotography.com.error.log;


root /var/www/ryansmithphotography.com/htdocs;



index index.php index.html index.htm;


include common/w3tc.conf;
include common/wpcommon.conf;
include common/locations.conf;
include /var/www/ryansmithphotography.com/conf/nginx/*.conf;

} server { listen 80; server_name ryansmithphotography.com; return 301 https://www.ryansmithphotography.com$request_uri; }

Thanks for the help.


#2

Hi @rsmith4321

You may ditch out w3tc for redis, update your current version of ee to latest using ee update.

Then, update your site’s caching to redis using ee site update yoursite.com --wpredis.

As this will resolve your issue, I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#3