Problem with large-screen responsiveness (two WP sites on same server)


#1

I have two nearly identical builds set up on a single Ubuntu VPS using EasyEngine. The first site is fine and responsive to both mobile and large screens. The second, however, works well, but is not responsive on a large screen. This is the case even at the admin level. Here’s a screenshot comparing the two with the newly created one on the left.

Both sites were created using the same methodology (ee site create www.example.com --w3tc). And while both sites use the same theme and CSS, I noticed this strange behavior on the raw site before I uploaded any content or migrated my database. I hoped that it would resolve itself when I migrated my theme, plugins, and database over, but it did not.

I cleared my caches on the site, browser, and most recently ran: sudo ee clean --all

This is the response:

Cleaning MemCache
Cleaning NGINX FastCGI cache
Cleaning opcache
Unable to clean opcache
Redis is not installed
Unable to clean pagespeed cache

The only other modification I made in between creating the first site and the second is running an update on the server.

I appreciate any assistance on this.


#2

I don’t see how your problem can be related to EE, however if you are using w3 Total Cache(w3tc), ee clean --all won’t have any effect.

Try clearing w3 TC cache, or better still disable it temporarily and see if the problem persist.


#3

@faizi

Thanks for the suggestion and the knowledge. I’m still trying to get a handle on the caching methods.

I tried your method and the issue I describe still persists.

The reason I believe it is an EE issue is that it has this behavior out of the box (so to speak). I created the site and it behaved in this way (on large-format screens) at its default state, before any personal mods or uploads.

To troubleshoot and eliminate one other potential culprit (me), I will rebuild the Linode and create both sites in sequence before doing any securing of the VPS. This is the only move I made between creating Site 1 and Site 2. I’m not sure if this may have caused the issue, but I will let you know soon.


#4

Hello again,

I set-up the VPS again and ran both ee commands at root level in sequence. The screen shots of the resultant sites are here before any configurations to the server or site databases.

A small correction, I am using --wpfc to install my sites.

I’m still not quite sure what might cause this bizarre behavior. I followed the guide on your site as well as WPAxl’s handy configuration guide. Is EE only configured to build a single Wordpress site per server unless one is using multisite?

Again, the issue only appears on large-format screens. The sites are identical on mobile, etc.

Thanks for your attention.


#5

Sorry, but my site? I’m not affiliated in any way with EE. I’m just a user(and a fan), just like you :slight_smile:

By the way your screenshot is not loading. IMHO, responsiveness rules are handle by CSS style in WP, so you might to take a look at that.


#6