Problem updating EasyEngine


#1

Hi!

First of all I want to thank you for EasyEngine, what a great tool! For me, who really is a novice when it comes to handling my own VPS, it really has helped me a lot.

I’m having a problem though: I can’t seem to update the version of EasyEngine.

I have created a file called .bash_aliases, where I have defined the following:

alias eeupdate=‘wget -qO eeup http://rt.cx/eeup && sudo bash eeup’

But, when I run the two commands:

source ~/.bashrc

And then:

eeupdate

The terminal just freezes. I have no idea why and I would really like to be able to upgrade to the latest version.

Any hints on what I can do?

Thanks again!

// Jens.


#2

@ jensfilipsson,

Why did, you create .bash_aliases file, there is no need as such for single alias.
Please refer wiki, to take effect.

If you still face same problem send us following command output

  
ee version  
cat /var/log/easyengine/*  

#3

Well, as I wrote before, I’m a beginner when it comes to this. I did refer the Wiki and tried to write those commands in the terminal, without any luck.

Then I turned to Google, where .bash_aliases seemed the way to go.

Now I’m thinking about making a complete backup of WordPress and then wipe the server. I think that might be the best option, to start over with a fresh install.

What’s the best way to do this?

// Jens.


#4

Hi jensfilipsson,

Revert changes in .bashrc you made for adding .bash_aliases .
go as per wiki for update and Lets check us the version you are using so please provide the output of above commands.


#5

Hello @harshadyeola ,

I hope your query is resolved. I am closing this support ticket for now.

Feel free to create a new support ticket if you have any queries further. :slight_smile:


#6