Postfix config problem after re-installing


#1

I updated my Ubuntu 14.04 server, which included a Postfix upgrade. When it finished, I started to get 500 errors when trying to send an email from my Drupal website. I purged and re-installed Postfix. Since then, I can send/receive emails from the server, but not from the website. I believe I have a problem with the Postfix main.cf file. Below is an image of it. I would really appreciate some help.

myorigin = $mydomain myhostname = abc. example.com alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases mydomain = example.com mydestination = $myhostname, $mydomain, localhost.localdomain, localhost mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 MAILDIR=$HOME/Maildir mailbox_command = /usr/bin/procmail -a “$EXTENSION” DEFAULT=$HOME/Maildir/ mailbox_size_limit = 0 recipient_delimiter = + virtual_alias_maps = hash:/etc/postfix/virtual sender_bcc_maps = hash:/etc/postfix/bcc sender_dependent_default_transport_maps = hash:/etc/postfix/dependent home_mailbox = Maildir/ smtpd_sasl_auth_enable = yes smtpd_sasl_security_options = noanonymous broken_sasl_auth_clients = yes smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu) biff = no append_dot_mydomain = no readme_directory = no smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key smtpd_use_tls=yes smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination


#2