Positioning the logo like RTcamp.com


#1

Hello,

I’m using RT panel theme. I have a 52x52px logo. I want to position my logo like RTcamp.com. Any suggestions?


#2

Hello,

Can you provide a site link?


#3

Hello Sagar,

here is the site link http://kefirci.com/


#4

Hello Kturgutoglu,

Are you using rtPanel Child Theme or doing changes in rtPanel theme itself?


#5

it is just rtPanel theme not a child theme


#6

Hello Kturgutoglu,

I recommend you to use child theme instead of doing changes in parent theme directly. For more details check out following links.

http://codex.wordpress.org/Child_Themes
https://rtcamp.com/rtpanel-example-child-theme-released/

After using child theme you can easily customize the theme as per your requirement.

Let me for further assistance.

Thanks


#7

Now I’m using the child theme but it didn’t solve my logo problem I guess.


#8

Hi Sagar,

I changed my rtPanel theme to rtPanel child theme. I checked options page of the theme. But there is no option to position my logo on the top left of the menu.

Can you help?


#9

Hello,

Add following line of codes in child-theme -> lib -> rtp-custom-hooks-applied.php on line number 23

remove_action( 'rtp_hook_begin_header','rtp_default_nav_menu' );  
add_action( 'rtp_hook_after_logo','rtp_default_nav_menu' );

After than line following line of codes in style.css

.rtp-header-wrapper {  
	background: #DDD;  
	margin-bottom: 30px;  
}  

.rtp-header-wrapper .rtp-section-container {  
	background: transparent;  
}  

.rtp-nav-wrapper {  
	background: transparent;  
	clear: none;  
    float: left;  
    margin: 0;  
}  

.rtp-nav-wrapper:after,  
.rtp-nav-wrapper:before {  
	display: none;  
}  

.rtp-nav-container a {  
	color: inherit;  
}

Given style are just an example, you can modify as per you requirement.


#10

Hello Sagar,

Thanks for your help. I feel like I’m almost there but there is a problem. When I scroll down the top menu comes down but logo stays at the same place. What can be the solution for that?


#11

Currently you are adding position: fixed to #rtp-primary-menu.

Just use #header-wrapper instead of #rtp-primary-menu


#12