Port 443 not listening after apt upgrade


#1
# sudo netstat -tulnp |grep nginx
tcp        0      0 0.0.0.0:22222           0.0.0.0:*               LISTEN      4745/nginx: master
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      4745/nginx: master
tcp6       0      0 :::80                   :::*                    LISTEN      4745/nginx: master

I don’t even know where to start troubleshooting. My sites use LE and have SSL.conf included in site.conf

site conf:

server {
    listen 80;
    server_name www.site.com site.com;
    return 301 https://site.com$request_uri;
}
server {
    server_name site.com www.site.com blog.site.com;
    access_log /var/log/nginx/site.com.access.log rt_cache_redis; 
    error_log /var/log/nginx/site.com.error.log;

    root /var/www/site.com/htdocs;  
    index index.php index.html index.htm;

    #include common/php.conf;
    include  common/redis.conf;  
    include common/wpcommon.conf;
    include common/locations.conf;
    include /var/www/site.com/conf/nginx/*.conf;
}

/var/www/site.com/conf/nginx/ssl.conf;

listen 443 ssl http2;
ssl on;
ssl_certificate     /etc/letsencrypt/live/site.com/fullchain.pem;
ssl_certificate_key     /etc/letsencrypt/live/site.com/privkey.pem;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
ssl_prefer_server_ciphers on;
ssl_ciphers "EECDH+AESGCM:EDH+AESGCM:AES256+EECDH:AES256+EDH";
ssl_ecdh_curve secp384r1;
ssl_session_tickets off;
ssl_stapling on;
ssl_stapling_verify on;
resolver_timeout 5s;
add_header Strict-Transport-Security "max-age=63072000; includeSubDomains; prel$
add_header X-Frame-Options DENY;
add_header X-Content-Type-Options nosniff;

#2

I just rolled back the server to fix.