Plugin does not show any option to brose and upload


#1

Hi,
This plugin does not give one the option to browse and upload media.
I have also copied the template over. Still nothing is happening.
I have been on this for about 48 hours now.
What could be wrong please?
I have also attached a screenshot of the options i have from the media page.When i click on “select” nothing happens, page just stays the way it is.
And when i click on “upload” i get an error message like

Fatal error: Uncaught exception 'RTMediaUploadException' with message 'No file was uploaded' in /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/processors/RTMediaUploadFile.php:116 Stack trace: #0 /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/processors/RTMediaUploadFile.php(27): RTMediaUploadFile->set_file(false) #1 /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/RTMediaUpload.php(63): RTMediaUploadFile->init(false) #2 /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/RTMediaUpload.php(39): RTMediaUpload->upload(Array) #3 /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/RTMediaUploadEndpoint.php(38): RTMediaUpload->__construct(Array) #4 /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/template/ in /home/xxxxxxxx/public_html/xxxxxxxx.xxx/wp-content/plugins/buddypress-media/app/main/controllers/upload/processors/RTMediaUploadFile.php on line 116PHP 5.2.17 MYSQL 5.5.23 WordPress 3.6 BuddyPress 1.8 rtMedia 3.0.0 OS Linux Imagick ImageMagick 6.7.6-8 2012-05-02 Q16 www.imagemagick.org GD bundled (2.0.34 compatible) [php.ini] post_max_size 64M [php.ini] upload_max_filesize 64M [php.ini] memory_limit 256M

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/4848/2013/08/Screen-shot-2013-08-02-at-11.57.44-AM.png


#2

I was having the same problem and it is now fixed! First of all deactivate any theme you are using. Then go into ‘plugins’. Deactivate and delete rtMedia and Buddypress. Then go to ‘Settings->General’ and check ‘anyone can register’. Remember to ‘save’ at bottom of page. In ‘Settings-> Permalinks’ change to ‘day and name’. Do not use ‘numeric’. Save it. Re-install and activate Buddypress. In ‘Settings-> Buddypress’ activate all the components. Save. Still in Buddypress settings, click on the tab next to components (called pages) and make sure the register and activate pages are set to ‘register’ and ‘activate’. Save. Now re-install rtMedia and activate it. Go to 'rtMedia->settings and you should be in the ‘general’ tab. Turn on all of the general settings. Save. Click on the next tab (types) and turn everything on. Save. Under the privacy tab I enabled privacy ‘default-public’ with user override on. Save. Then in the last tab of rtMedia (buddypress) I enable all the activities. Save. You don’t have to save each tab, just at the end. But it doesn’t hurt. Now I logged out of admin, closed and reopened my browser and when I logged in as a member everything worked great! Hope this helps.


#3

@tanzengeist - Thanks for the support.

@mixy - could you confirm if that solves your issue.


#4

@tanzengeist Thanks for your help. Unfortunately, it did not help my situation.
Followed every detail of your instruction but am exactly where i was.
I would appreciate some help with this.

@joshuaabenazer It did not solve my issue. Looking forward to some help from you, hopefully. Lol. Thanks a lot.


#5

@mixy - I noticed that you are using an older version of php. Try asking your host providers to upgrade your php and check.


#6

@joshuaabenazer I have just upgraded the php to 5.3 and it does not change anything. Still having the same problem. Although am not getting the error message. But nothing happens when i click on select.


#7

Ok try and see if it works with the default theme and with all the other plugins deactivated.


#8

Done as you instructed. Still same problem.


#9

A link to your site would be helpful.


#10