PhpMyAdmin not loading Browser giving ERR_CONNECTION_TIMED_OUT error


#1

I’m unable to access the PhpMyAdmin page, I have tried to access it using both “IP:22222” and “website.com:22222” without any luck.

the eror is same on Chrome and Firefox. Also tried using the incognito mode.

I have installed PhpMyAdmin using

ee stack install --admin

I can see the PhpMyAdmin folder inside var/www/22222/htdocs/db/

I also tried to allow the port 22222 into firewall inbound and outbound setting but even that didn’t work.

Let me know if I’m forgetting something.


#2

Check your firewall. Allow traffic to port 22222.


#3

I have allowed port 22222 on windows defender, I checked the link on my mobile and its giving me same connection timed out error.


#4

I’m not talking about your PC. Check your server firewall.


#5

I allowed port 22222 on ufw using

sudo ufw allow 22222

and that worked!

But I’m getting SSL certificate invalid issue on that page, How can I fix that?


#6

Hello,

it’s a self signed certificate, that’s why it’s show as not valid, but that doesn’t mean there is no encryption of your connection.

But if you still want to use a valid SSL certificate, you can use a cert installed on of of your site. To do so , just set your domain name as a variable (a domain with an ssl certificate) :

MY_DOMAIN=yourdomain.tld

Then run the following command :

        sed -i "s/ssl_certificate \/var\/www\/22222\/cert\/22222.crt;/ssl_certificate \/etc\/letsencrypt\/live\/${MY_DOMAIN}\/fullchain.pem;/" /etc/nginx/sites-available/22222
        sed -i "s/ssl_certificate_key \/var\/www\/22222\/cert\/22222.key;/ssl_certificate_key    \/etc\/letsencrypt\/live\/${MY_DOMAIN}\/key.pem;/" /etc/nginx/sites-available/22222

check if the configuration is correct and reload nginx :

nginx -t && service nginx reload

Then you should be able to access to EE backend under https://yourdomain.tld:22222