PHP Warning: Cannot use a scalar value as an array


#1

PHP Warning: Cannot use a scalar value as an array in /xx/xx/wp-includes/class.wp-scripts.php on line 167

This error is spitting out any time a page loads. I disabled all plugins and enabled them one by one. Your plugin caused the error.

Is this a known bug?

WordPress 4.0 Buddypress 2.1.1 rtMedia 3.7.15


Update 3.7.15 problem
#2

I have the exact same error. It happened after I upgraded the plugin.

Warning: Cannot use a scalar value as an array in /home/cmac/public_html/wp-includes/class.wp-scripts.php on line 167


#3

Try re-saving your settings and report back.


#4

Hey,

Thanks for taking the time to follow up! This fixed it.


#5

For those who are still facing this issue, we are not able to reproduce the same on our end, any information will be helpful to solve the issue.


#6

Hey,

All I can say is I upgraded from the previous version and started noticing the errors. If this doesn’t replicate it, I can try giving you my settings.

Let me know what you’d need.


#7

Hi @all,

We have figured out the issue and has been fixed in new release i.e. rtMedia 3.7.16. Please update and check with new release and if you find any issue let us know.


#8