PHP-FPM5 spikes to 100% CPU usage


#1

Having this problem once a week or so and never seem to find anything in my php error logs that would relate to such a massive spike which often runs two hours or more (until I restart php-fpm).

Saw someone posted about changing pm.max children settings, but I don’t have those in my fpm config?

Any other tips? I paid RT to tweak all the settings a few months back, but not sure if these spikes are because something was missed or that usage has increased too much for my capacity. (40 GB disc with 4 GB swap.)


#2

Change settings to pm = ondemand?

http://linuxbsdos.com/2015/02/17/how-to-reduce-php-fpm-php5-fpm-ram-usage-by-about-50/

have seen numerous posts about this, but can’t find any pm = settings in the config file.


#3