Php-fpm causing high cpu usage


#1

Hi I have linode 2GB plan on Ubuntu 14 LTS - Nginx -Php5 and suddenly from last 2 days php-fpm is using all the cpu resources from 20% to 190%.

Any idea how can I reduce this usage and get it to normal?


#2

Hi,

Which caching mechanism you are using on your site? We recomend you to use fastcgi cache mechanism.

Also Open www.conf file:

vim /etc/php5/fpm/www.conf

and change:

pm.max_children = 20

After that you need to restart PHP5-FPM

php5-fpm -t && service php5-fpm restart

#3

Hi,

I was using W3 Total cache. Now disabled because of high cpu usage.

The max children is currently set to 10. Should I increase it to 20? (refer below screenshot)


#4

Thank you, seems like increasing the value is working. But, still it’s not fully back to what it was.

Anyways, thank you very much.


#5