PHP Errors and complete lockout without Groups enabled!


#1

Hi all,

I was trying out this plugin for a new niche network site and I too am getting the previously reported PHP errors:

On the dashboard:

Warning: Division by zero in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-admin-reassign.php on line 308

    <b>  

Warning: Invalid argument supplied for foreach() in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-admin-reassign.php on line 878

Warning: Invalid argument supplied for foreach() in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-admin-reassign.php on line 840

Warning: Invalid argument supplied for foreach() in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-admin-reassign.php on line 786

On the Photo and Video pages:

Warning: Division by zero in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-classes.php on line 517

Warning: Division by zero in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-templatetags.php on line 91

Plus the warning ‘There were no Media Content found.’

This is after a fresh install so there is no content yet?

The WORST thing though is that the plugin wont activate without the ‘groups’ feature of Buddypress enabled, and then after you activate the plugin, if you disable the groups feature you cant access Buddypress at all anymore, it just shows a PHP error (sorry i didnt get a copy of it before I deleted this broken installation, oops) You cant access anything, not even the management dashboard to re-enable groups!

Wordpress SU 3.0.1
BuddyPress 1.2.5.2
BuddyPress Media Component 1.2.5

This is a fresh clean installation…i can give you admin access to help debug if you want?


#2

Hey, rups, just check out the new version, I will be posting regarding it soon :slight_smile:

Warning and 99% bugs are taken care of in this version.
Thanks for your feedback :)

#3

Hi Kapil,

Thanks very much for the update, all the error messages are gone now :smiley: however when I deactivate Groups in Buddypress the plugin still locks out the entire installation :frowning:

If I try to activate the plugin whithout groups enabled, I get a ‘Fatal Error’ at the top of the plugin page:

Fatal error: Class ‘BP_Group_Extension’ not found in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-group.php on line 5

If I enable Groups, activate the Media Component pluging then disable Groups then no matter what page I try to access, including the dashboard, I get the following error:

Fatal error: Class ‘BP_Group_Extension’ not found in /…/wp-content/plugins/buddypress-kaltura-media-component/bp-media-group.php on line 5

This is the same error as when trying to activate it. This locks out the entire WP installation so I can’t even re-enable Groups. I have to delete it all and start again :’(

Wordpress SU 3.0.1
BuddyPress 1.2.5.2
BuddyPress Media Component 1.2.5.1

I am trying on a completely fresh installation with no other plugins and with the default BP theme.

Cheers,

rups


#4

Looks like this is a BP 1.2.5 / WP 3 incompatibility issue as the author has posted previously. It might make sense to put up a blog post about the version incompatibility to clear up the confusion as it seems loads of people are running into this issue?

Unfortunately, I am stuck with WP 3 so I’m going to have to put my development on hold until this is fixed…there is no rush but it would be nice to have some indication if / when this will be looked at as this component looks really good and would be Perfect for my site :slight_smile:

Cheers!


#5