PHP 7 makes site unreachable... 5.6 was working fine


#1

Hi all,

I was using php 5.6 with ioncube loaders for 5.6 and everything was working fine with my site. (just a site, not wordpress). Then installed the new ioncube loaders (which work also with php 5.6) and everthing still worked fine.

Then I installed php 7 though the ee command : ee stack install --php7 and later ee site update example.com --php7 .

When I go to my site I now get : a message that the SITE CAN’T BE REACHED …

It’s not the firewall, cause I switched it off to see what happens …

Anyone have an idea why this is ? btw. My site is a php script named CPVlab … so I don’t know if that’s the problem …

Anyone ?

Lex


#2

Did you try reverting back to php5.6?

What’s the result of curl -IL yourdomain.com?


#3

yes … tried reverting back … that leads to htdocs folder that’s empty. The backups are still there, however some settings seem to not revert back… That will lead me to rebuild from the snapshot I made on linode …

Curl gives me :

HTTP/1.1 200 OK Server: nginx Date: Tue, 21 Feb 2017 13:26:07 GMT Content-Type: text/html Content-Length: 612 Last-Modified: Thu, 25 Aug 2016 22:21:47 GMT Connection: keep-alive Vary: Accept-Encoding ETag: “57bf6f7b-264” X-Powered-By: EasyEngine 3.7.4 Accept-Ranges: bytes

This seems to be OK … or am I missing something simple here ???


#4

This is a bug on EE: if you change anything on a non-WP site, it will wipe your htdocs directory.

You can get your site back, just copy files from htdocs in one of your backups to the actual htdocs directory and you’ll be good to go.


#5

Yes I though so … however … I’d like to use PHP7 … it’s faster and speed is what I need … :slight_smile:


#6

Restore your site, update it to PHP7 and restore your files again, and you should be good to go.


#7

I;ve done that … the files are all there … but I get the same message … maybe the php script that I am using (CPVlab) is just incompatible ?


#8

Ok … the admin tools work … and there are php files in there … So PHP should work. …I think it’s the script / ioncube or so that I am using … it can’t be anything else … otherwise the admin tools shouldn’t work either …


#9

Ok … I was wrong … the admin tool somehow are still using 5.6 … while the site is using 7 (checked it with php -v) … it doesn’t work and i am going back to 5.6 cause I don’t have time for this …


#10

First, test is all you wordpress is compatible with php7 with this tool https://wordpress.org/plugins/php-compatibility-checker/


#11

He is not using wordpress, What is the actual error code returned? Use curl when you get that error and see what the responce code is. Then check your logs. There is a logs folder next to the htdocs which will tell you what is causing the error. Caching could be a problem here. Worth a check.

If you dont have time to debug dont make changes. No matter how easy. A 1 minuet job always takes 10. :wink:


#12

Thanks to all for the replies … I found out that the script I’m using is still not working with php 7 … I emailed them and they told me they are working on it …

Lex


#13