Permalink problem


#1

Hey there,

I just bought rtMedia and I’ve installed the latest version with the latest versions of WP, BuddyPress, and bbPress.

I’ve tried flushing my permalinks, deactivating and reactivating the plugin, and disabling other plugins. When I click on “Media” in my profile, it leads me to my index.php template – this happens whether in a profile or inside of a group.

I have tried a default theme and it does seem to work there, however, everything else except for rtMedia seems to be broken (everything is blank except for this plugin’s media page). On my custom theme, it’s the opposite – everything works fine except for rtMedia.

Is there something I need to add to allow compatibility with my theme and rtMedia? My theme is custom, but it’s based off of a premium theme called “OneCommunity” from ThemeForest.

Thanks for any help!


#2

I made an account so I could reply to you. I was having same problems. This solution fixed it for me and its simple. =)

rtMedia uses a custom permalink structure. To use rtMedia pretty permalinks must be enabled. So first check if they are enabled.

When rtMedia is freshly installed, it refreshes WordPress’s permalinks, automatically. At times, this doesn’t happen and you’d have to manually refresh them. To do so, go to, Settings >> Permalinks and just Save Changes. This will refresh the permalink settings and rtMedia custom permalinks will start working with WordPress.


#3

Hey Thunderpeel,

Thanks for the help. I actually have tried this before (I flushed the permalinks), so this hasn’t worked for me.


#4

Hi guys,

@gshock seems like you already got answer for the question :slight_smile: .

@thunderpeel Thank you for giving resolution.


#5

@gshock can you please confirm if you are still facing issues?

If yes, can you email your wordpress login details to ritesh.patel@rtcamp.com (lead developer on rtMedia). We will surely provide all the help.


#6

Thank you, Rahul. I’ve sent an email.


#7

@gshock, as per our conversation over the mail, this is a theme issue.


#8

I talked to the theme author and he said to say that the theme is based off of bp-default, and rtMedia is incompatible with it (it’s a theme that comes with every BuddyPress installation). There’s another topic about it here:

So the theme author says it’s a plugin problem and you guys say it’s a theme issue. I’ll look into it myself and let you know if I make any progress.


#9

Additional EDIT: I feel like I may have sounded rude. Totally not my intention! You guys are doing a great job and thank you for making rtMedia.


#10

@gshock, by default rtMedia use theme’s index.php.

Try putting this code in your theme’s functions.php file and check if this fix the issue or not.
It will use page.php instead of index.php

function rtmedia_main_template_include($template, $new_rt_template) {  
	return get_page_template();  
}  
add_filter('rtmedia_main_template_include', 'rtmedia_main_template_include', 20, 2);

#11

That works! Thank you very much.


#12

Oh, last question: is there a way to change this to a non-standard WordPress page? Such as if I make a new template called imagespage.php?


#13

Hello @Gshock,

You can use your own template. Just use the function “locate_template(‘your-template-name.php’)” instead of “get_page_template()”.

We are glad your issue is resolved. Please feel free to contact us if you have further issues.


#14