Orangescrum on easyengine


#1

Hi, I have installed easyengine and want to set orangescrum isntance on it what I could achieve till now is attache screen

I have followed all the instructions and also have written rewrite.conf in ngnix/conf/. Can someone please guide how to proceed.

One more thing I want to set up moodle site the same server, Is is possible?

Regards, Geeta


#2

Not 100% sure what you’ve done so far, but it sounds like you have added a domain and php/mysql already? (if not, check the easyengine create command).

I don’t know orangescrum but I did notice they state Apache as a requirement for the web server. As easyengine uses Nginx you might want to check orangescrum to see if it will run under Nginx (pretty sure it will), and if they have a guide to what you need to do differently.

Other than that, it just looks like you need to need to follow the 4 steps above - it’s not really an easyengine thing from here on (you can use the standard MySQL command line tool or phpmyadmin for creating/importing databases).

Re: moodle, do you mean on the same server or on the same domain?


#3

Hi, It is possible to set the orangescrum on nginx . The link as below:

I have created the site as sudo ee site create orangescrum --mysql and done the changes as stated on the ngnix page. Yet could not achieve what I want.

For Moodle created a different site as sudo ee site create mymoodle --mysql

both the things don’t work :frowning:

Can you please help me setting up these sites locally.

Regards, Geeta


#4

Hi, I want to rewite urls can you please guide as where and how can I do that ? Regards, Geeta


#5

So have you done the steps 1 to 4 from your first post? If not, that’s what you need to do next. If you have, what happens now?


#6

Hi Marty,

I have done the following

vi /etc/nginx/conf.d/virtual.conf

server { listen 80; server_name orscommunity.com www.orscommunity.com; access_log /var/log/nginx/orscommunity.com.access.log; error_log /var/log/nginx/orscommunity.com.error.log; root /var/www/html/public_html/OS_Community/orangescrum-master; index index.php;

use fastcgi for all php files

Are you sure you have this set

up? location ~ .php$ { fastcgi_pass 127.0.0.1:9000; fastcgi_index index.php; fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name; include fastcgi_params; } location / { try_files $uri $uri/ /index.php?$uri&$args; rewrite ^/$ /app/webroot/ break; rewrite ^(.*)$ /app/webroot/$1 break; }

deny access to apache .htaccess files

location ~ /.ht { deny all; } }

Can you suggest where do I put this code so that my rewrite actually work I tried this putting in sites-enabled/default also tried putting in sites-enabled/orangescrum And restarted the stack, still rewrite doesnot work

Regards, Geeta


#7

If you look at sites-enabled/orangescrum you’ll see that easyengine works by using various include files. The last of which will be:- include /var/www/orangescrum/conf/nginx/*.conf; Which includes anything in that folder ending in .conf - so that’s where your site level changes should be. But I’d also recommend looking at all the include files being used as you need to understand what is already being done before you start adding more rules. e.g. it makes no sense to be pasting in “server_name orscommunity.com” again because that rule is already there (and it’s a different domain…?).


#8

Hi Marty, Thsank for your reply. I have tried added the server name as / or /orngescrum . But it seems that redirection is not handled. Is there anything else which I probably have missed ? I have followed each and every instruction of the the link just that I have set up the site locally. Regards, Geeta


#9