Not upload in activity v. 2.13


#1

It does not work the option of uploading in version 2.13. My debug information: debug information

PHP 5.4.14 MYSQL 5.5.30 WordPress 3.5.1 BuddyPress 1.7.1 BuddyPress Media 2.13 Linux OS Imagick Not Installed GD bundled (2.0.34 compatible) [php.ini] post_max_size 100M [php.ini] upload_max_filesize 100M [php.ini] memory_limit 256M

thanks

Enable option upload activity


#2

Hi, Could you post a link to your website?


#3

Hi, in my case, file is uploaded, I can see / listen it from my profile but none player is available for video & audio (if image, all is right) in my status update

NB: no problem from profile page, with “drag n drop” uploader

mine are the following
PHP 5.3.26
MYSQL 5.1.69
WordPress 3.5.1
BuddyPress 1.7.2
BuddyPress Media 2.15.3
OS Linux
Imagick Not Installed
GD bundled (2.1.0 compatible)
[php.ini] post_max_size 100M
[php.ini] upload_max_filesize 100M
[php.ini] memory_limit 256M

voila :wink: many thanks in advance

PS: Twenty Twelve child theme, disabled my other activity plugins

do you need more info? my website is not publicly online


#4

Hi,
By default the player does not show up for multiple uploads. For multiple uploads we show a default thumbnail for audio/video. If you upload an audio or video individually then they show up in the player.
Could you confirm if a single audio or video upload shows up in a player on your status update?


#5

Hello Joshua, thank you for this quick reply

Well, in fact not tried multiple uploads from your “Attach Media” button below “what’s new” box, only single but no :frowning: audio / video player is not show up into my status updates (checked out “source”, there is nothingelse than my text into this DIV “activity-inner” class)

PS: If attached from group home activity wall, the following error is displayed “Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/laurett/public_html/…/community/wp-includes/post.php on line 2996”

NB: When file is uploaded from my profile / group’s upload tab, using uploader then player it’s available :slight_smile: perfectly

I could see something in my database if needed :wink: I will do more test…


#6

Ok, could you try checking it on the BuddyPress Default Theme with all the other plugins deactivated.


#7

re, it’s still not better with bp default theme

previously, used Activity Privacy and Checkins plugins but they are disabled now…


PS: My audio & video file names are cleaned up

I could try on a fresh install but need time :wink: to do it


#8

That is strange. Would need to have a look at the site to debug it better. Let me know if the problem exists on the new install.


#9

New install in progress’… and then I will forward its link :wink: as soon as possible

nice w/e to you :wink: thank you, one more time for your support…


#10

done but player is still not showed up on status updates

I 'll send my address privatly because at this point it’s a test only :wink: many thanks in advance, @joshuaabenazer may be an administrator account is needed ?


#11

I can’t send to you a private message, then my address is the following
http://test.teknik3d.com/bp/activity/


#12

Could you send me the administrator credentials at joshua.abenazer@rtcamp.com


#13

yes, of course ;-) it' done for now...

not see this option "set as private reply" here ;-) it's to late


#14

Hi,

I just had a look and I got this warning when I tried uploading an audio or video file through activity:

Warning: realpath() [function.realpath]: SAFE MODE Restriction in effect. The script whose uid is 613 is not allowed to access /tmp owned by uid 0

Due to this warning the activity upload doesn't function properly since it messes with the response. Try disabling safe mode in your server php.ini file


#15

this was a private reply with post_id 40271


#16

Hi, I used the inspect element option on chrome to play around with the markup just to see if it works right. Even though your safe mode is off it still shows the same warning. Could you try setting WP_DEBUG to false in your wp-config.php file and check if it works.

define('WP_DEBUG', false);  

#17

Ok, I tryed WP_DEBUG and WP_DEBUG_LOG = true ;-) then it seems I 've made something wrong because the following error said than safe_mode is still activ... is not ?

PHP Warning:  realpath() [function.realpath]:   
SAFE MODE Restriction in effect.    

The script whose uid is 613 is not allowed to access /tmp owned by uid 0 in /home/xx/public_html/.../wp-content/plugins/buddypress-media/lib/getid3/getid3.php on line 22

I don't understand, when I look my phpinfo, it's displayed safe_mode: Off safe_mode_exec_dir: /usr/local/php/bin safe_mode_gid: Off safe_mode_include_dir: no value

Voila ;-) thank you @joshuaabenazer one more time


#18

Try setting WP_DEBUG to false and see if that helps.

Else try contacting your host provider and ask them if they can switch the safe_mode off.


#19

yeeaaah! it's fixed for now... many many thanks @joshuaabenazer for your support in fact this safe_mode has been truely disabled and then ;-) now it seems right... from "what new?" box / "attach media" button


#20

Glad to know its fixed :)