No toolbar or footer on album page


#1

Hi!

I have a problem with the Albums-page. The Wordpress toolbar and the footer have disappeared. I use BuddyPress, so with “Albums”-page I mean the page that lists all the albums belonging to a specific member (like mysite.com/members/username/gallery/album).

The other rtMedia-related pages, like “All” or “Photos” or global gallery are working fine.

I have the latest versions of Wordpress, BuddyPress and rtMedia. This happened after I updated both WP, BP, rtMedia and a bunch of other plugins pretty much at the same time, so I don’t even know where to start looking.

Suggestions?


#2

As a rule of thumb, if it’s a display issue, look at the theme. If it’s a broken issue, look at the plugins! :slight_smile:

Try switching to TwentyFifteen as your theme. If it works there, it’s a theme issue.

If it does not work there, post up a screenshot and circle what’s wrong that way it makes more sense. :slight_smile:

You can always restore your backup (you do have one, made with Duplicator, a free WP plugin, right?) and then update plugins and such one at a time (and you should in the future, too!).

Ben


#3

Turns out the problem was a hidden sidebar.

I have a sidebar widget that shows the latest photos from the global gallery on the front page. The sidebar was not properly disabled on the Buddypress-pages, just hidden with display:none. When I disabled the sidebar, instead of just hiding it, the Album page returned to normal. :slight_smile:


#4