Nginx stack installation error


#1

Hello everyone,

I’m trying to install nginx stack on a fresh debian 8 installation, but getting the following error message:

The following packages have unmet dependencies: nginx-custom : Depends: nginx-common (= 1.8.0-9ppa) but 1.8.1-1~dotdeb+8.1 is to be installed

It seems like dotdeb updated their package.

thanks,

K


#2

@angelgmartinez

Thanks for the info. Will check and let you know about the issue.


#3

@angelgmartinez

We have updated our nginx repository for latest nginx stable version.

checkout if your issue fixed?


#4

@harshadyeola I believe that my issue is related to this one (my Nginx-Mainline thread which I posted a couple before this thread).

Have you updated your repository to the latest nginx-mainline as well?

Thanks!


#5

@harshadyeola haven’t had the time to try it. Ended up installing ubuntu.


#6

@WZRD

yes we have updated EasyEngine repository for both stable and mainline.


#7

@harshadyeola

Looks like we’re still getting an error, albeit a slightly different one: nginx-mainline : Depends: nginx-common (= 1.9.10-1ppa) but 1.9.10-1+trusty0 is to be installed Conflicts: nginx-light but 1.9.10-1+trusty0 is to be installed

Before it was throwing an error about 1.9.7 so it’s updated but it’s still conflicting with the Ubuntu Trusty

Thoughts?


Unable to update nginx-common
#8

@WZRD

looks like you have some other nginx repository configured for nginx. please check your sources.list file.


#9

After removing all of the standard Ubuntu trusty nginx repos from my nginx sources list I was able to get nginx-custom to work.

This is all new to me - customizing repos and the like.

I think I’m going in the right direction.


#11