Nginx settings for fastcgi & w3 total?


#1

Hi,

I use rtcamp nginx, everything was going great until I installed w3 total, according to: https://codex.wordpress.org/Nginx

in server{…} block there is:

# POST requests and urls with a query string should always go to PHP
if ($request_method = POST) {
        set $no_cache 1;
} 

But in W3 Total Cache there is:

# POST requests and urls with a query string should always go to PHP
if ($request_method = POST) {
        set $cache_uri 'null cache';
}   

Which one? I have fastcgi and use w3 to cache opcode as recommended by Rahul. Here is my sites-avail config: http://pastebin.com/fVtxW8qY These settings are not clearing my cache properly, what should they be? Thanks,


#2

Hi,

This is my current Nginx + W3 setup (snippet):

# POST requests and urls with a query string should always go to PHP
if ($request_method = POST) {
  set $cache_uri 'null cache';
}
if ($query_string != "") {
  set $cache_uri 'null cache';
}

Hope it helps!


#3