Nginx not upgraded, even though say "successful"


#1

Hi

So I used the “ee stack upgrade --nginx” command and it says it finished successfully However, I still got the old nginx version

I see no errors in the error logs (maybe I should look elsewhere) Any clue what do to?

Thanks


#2

@treelicker Did you update the EE first?


#3

Upgrading EasyEngine is not mandatory for upgrading the Nginx version. But it’s better to upgrade to latest EasyEngine as we’ve pushed the fix for the ee update command, which will not create issues when you try to update next time, and a few other fixes.

@treelicker Can you please share the output of

apt-cache policy nginx-ee

And

cat /etc/apt/sources.d/ee-repo.list

Please also share the log file after running the command

ee stack upgrade --nginx

#4

Updated both, yes. Using Debian 8.6 Also, the first time I tried to upgrade nginx, I got an error message relating Redis. It was ok after I stopped the services though

@mriyam.tamuli

nginx-ee: This text will be hidden Installed: 1.10.3-10ppa~stable Candidate: 1.10.3-10ppa~stable Version table: *** 1.10.3-10ppa~stable 0 500 http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/Debian_8.0/ Packages 100 /var/lib/dpkg/status

  1. “cat /etc/apt/sources.d/ee-repo.list” - no file or directory

ee stack upgrade --nginx

During package update process non nginx-cached parts of your site may remain down

Do you want to continue:[y/N]y

Updating packages, please wait…

Restart : nginx [OK]

Successfully updated packages


#5

Can I somehow force reinstallation?

And thanks for the help. Much appreciated


#6

Hello,

EE repositories are missing in /etc/apt/sources.list.d/ee-repo.list, That’s why you were not able to upgrade.

Use the command (as a single command, do not copy each line one per one) :

cat <<EOF >/etc/apt/sources.d/ee-repo.list
deb http://sfo1.mirrors.digitalocean.com/mariadb/repo/10.1/debian jessie main
deb http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/Debian_8.0/ /
deb http://packages.dotdeb.org jessie all
EOF

Then try again

ee stack upgrade --nginx

#7

Thanks virtubox, for your help

don’t have this path “/etc/apt/sources.d/”. Do you mean “/etc/apt/sources.list.d/”?

UPDATE:

  1. tried with sources.list.d => no change
  2. created sources.d and the ee-repo.list file + run the command you posted => no change

#8

You haven’t a directory sources.d in /etc/apt/ ? And what happen if you run the commands :

apt update 
apt --list-upgradable

#9

apt-get

3 packages can be upgraded. Run ‘apt list --upgradable’ to see them. W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org Release: The following signatures were invalid: KEYEXPIRED 1501595774

W: Failed to fetch http://download.opensuse.org/repositories/home:/rtCamp:/EasyEngine/Debian_8.0/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.

apt list --upgradable:

git/oldstable 1:2.1.4-2.1+deb8u6 amd64 [upgradable from: 1:2.1.4-2.1+deb8u5]

git-man/oldstable 1:2.1.4-2.1+deb8u6 all [upgradable from: 1:2.1.4-2.1+deb8u5]

nginx-common/jessie 1.12.2-1~dotdeb+8.1 all [upgradable from: 1.10.3-10ppa~stable]


#10

Update the GPG key :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv 3050AC3CD2AE6F03

#11

Now it works! thanks!!

why is it the keyserver.ubuntu and not something else?


#12

keyserver.ubuntu.com is a public GPG key server, it can be used by everyone.
But this issue is pretty old :


#13

@virtubox I used your nice https://github.com/VirtuBox/nginx-ee script to upgrade nginx.

Do you know why how to solve the following when running: ee stack upgrade ?

The following packages have unmet dependencies: nginx-custom : Depends: nginx-common (= 1.14.0-1ppa~stable) but 1.10.3-10ppa~stable is to be installed nginx-ee : Depends: nginx-common (= 1.14.0-1ppa~stable) but 1.10.3-10ppa~stable is to be installed E: Unable to correct problems, you have held broken packages.


#14