Nginx + IonCube


#1

Does anyone know the correct path to install the ioncube_loader in Ubuntu 14.04. Evidently the path to virtual host is different in this ver. I’ve been moving that loader file around for the last few hours and can not get it to execute in the browser. Any thoughts would be appreciated… thanks in advance.


#2

First EasyEngine always used latest packages (php 5.x)

As per our experience with ioncude it not works good with php5.4 and php 5.5
We always need to revert php 5.3 to support ioncube


#3

Thanks for the info on this… very much appreciated. Getting it done is another matter though. Using the tutorial at; sudo service php5-fpm restart, and restarting php, the output of “php -v” is still 5.5.

Any ideas?


#4

You need to remove/purge php5.5 packages
After that disable Ondřej php5.5 repository
rm /etc/apt/sources.list.d/ondrej*

Then install the php5.3 packages manually
After that you need to follow ioncube installation guide


#5

Exchanging 5.3 for 5.5 is not happening for me. 4 installs with easyengine all ended up with 502 Bad Gateway errors. Any input would be appreciated… thanks.


#6

Downgrade php5.5 to php5.3 https://github.com/rtCamp/easyengine/issues/194
502 BAD Gateway:
Seems like your /etc/php5/fpm/pool.d/www.conf file not listen on 9000 port
Open above file and change listen to 9000

vim /etc/php5/fpm/pool.d/www.conf  
listen = 127.0.0.1:900

Restart php5-fpm
service php5-fpm restart


#7

Hello @apprei9,

I hope your query is resolved. I am closing this support ticket for now.

Feel free to create a new support ticket if you have any queries further. :slight_smile:


#8