Nginx-helper + WP SuperCache


#1

Hi,

I’m facing some trouble in a Wordpress installation with nginx helper, wp-supercache and wpml.

The problems are in a post that has a lot of images attached to it (in the range of 100), so whenever the post is saved, WPML tries to sync all the attachments with the equivalent post in another language.

Because of that (and here is where the error comes), nginx helper tries to purge the cache for all images, even if nginx helper is set to not to have cache.

My question is: how can I disable nginx fpm cache at all? My understanding is that using WP SuperCache makes me not needing that feature of nginx-helper.

Am I wrong???

Also, do I need nginx-helper at all?


#2

You don’t need nginx-helper’s purge feature when using WP Super Cache.

Looking at your settings screenshot, nginx-helper is not doing any purging at the moment. Did your problem solved when you disabled plugin?


#3

Yes, with the plugin disabled the issue gets fixed, but with the plugin enabled like it’s shown in the screenshots, this is what I get in the php fpm slow log


#4