Nginx-helper, not removing index.php from permalink


#1

I believe I have the correct rewrite code in my nginx config for the site server, but after installing nginx-helper it is still not removing the index.php from permalinks. Is there an additional step I need to take? I do not see any options for permalinks in the nginx-helper plugin settings in wp-admin, and I have already tried changing the actual wp permalink settings back to normal and back again. WP 3.8.1 and latest stable nginx.

location / {
try_files $uri $uri/ /index.php?$args;
}


#2

bump


#3

Perhaps I am just misunderstanding the way this plugin works. In Dahsboard/Settings/Permalinks, the pre-defined settings still have index.php in the path, although I expected it to be missing. Eg: Post name = http://example.com/index.php/sample-post/. However, if I set it to custom structure with /%postname%/, it seems to work fine. Is this expected?


#4

You need to remove index.php from Settings > Permalink if it's there. Then test blog posts/pages on site to see if they open without /index.php in their name.

Please let me if above this solves your question. Sorry for delayed reply.


#5

similar question, while busy testing a new server I see index.php in my permalinks:

while on my other server running more or less the same config I don’t even see it there:

Any idea how to remove that index.php from being even shown there?


#6