Nginx helper doesn't seem to be working


#1

In easyengine v3 I could get the Nginx timestamp to work, adding the info at the bottom of the page html. However this option is not working for me with v4, I’m not seeing any info added to the html. Also if I enable logging the log file is also empty. How can I tell if Nginx caching is working? My settings are
Hostname: ee-global-redis, Port 6379. Are these correct? I can’t figure it out.


#2

You can read the headers to see if your cache is working. Log out of your website and open the browser console, head to the network tab and reload the page then in the list of the resources that have loaded click on the page itself, usually it’s first on the list and just says “/“

The headers will say that it’s being served by nginx. There are also 2 headers for the cache which will tell you if the page was served from the cache, and/or if it was stored in the cache. Like if it says HIT for being served from the cache it means the page was served from cache. If it says BYPASS for store, it means the page was not saved in the cache (because there is already a saved copy of the page in the cache, so there is no need for that copy to be overwritten with a newer version for now)

I’m on mobile so this was probably a lot more confusing than it needed to be, I can’t post screenshots or the exact names of the headers. But have a look at your headers anyway and post them back here if you can so I can have a closer look


#3

I had this issue with a new website, but can’t remember exactly how I fixed it. Try enabling the timestamp in the plugin settings, purging the cache by clicking the Purge Entire Cache button, perhaps try restarting the site via cli, too - ee site restart example.com - then open the site in question in a private/incognito window to check the source code.


#4

Yes if I look at the headers now it does say HIT on the second view of a page it seems to be working. However the timestamp in the html and the log file from nginx helper still don’t work. The log file is always empty. I wonder if this is a bug that should be reported?


#5

Just tested logging and it doesn’t appear to be working - nothing is added to the nginx.log file in /wp-content/uploads/nginx-helper. Somehow I managed to get the timestamp to output in HTML though. Does seem buggy.