Nginx Helper doesn't purge


#1

Hi there, I saw that the plugin has been updated several times in the last period. Now i think that purge doesn’t work anymore

Before installing ngx_cache_purge module for nginx, i tried to set the method to “Delete local server cache files”. Checking the space of /var/run/nginx-cache from terminal (pre and post purge) the size doesn’t change so most of my sites have problem with display the new posts

Any hint? Thanks


#2

can confirm it is not purging after the recent updates - tried both methods. Only way to really clean/purge the cage is now via easy engine admin panel using clean.php


#3

Hi @mrmad @feedtek1

Thanks for reporting problem. we are looking into issue. and revertback here as soon as its solved.


#4

I’ve got his problem too.

  • Running clean.php or ee clean fixes it.
  • it won’t work at all “using Get request” but does sometimes work with “Delete local server cache files”
  • It won’t work at all using the “purge cache” button
  • It works when “delete local cache…” is selected and I update a page or post but not when I use “purge cache” button

This is on a Digital Ocean server, Ubuntu 14.04, clean install using ee site create example.com --wpfc --user=dev --email=thepauly@gmail.com --hhvm. No plugins other than nginx helper (I deactivated and deleted w3tc as everything ran slower with it on)


#5

I can confirm that this is broken in 1.8.10. If I revert to 1.8.9, it works as expected.


#6

where can I download the previous version?


#7

Hi @mrmad,

You can download previous version of Nginx Helper plugin from here: https://wordpress.org/plugins/nginx-helper/developers/


#8

We have the exact same problem and had to revert to 1.8.12. All nginx config options haven’t changed.


#9

Was this issue fixed? I’m trying the latest version and have tried both Purge Modes, but I’m unable to see it removing an files in my cache folder when clicking the Purge Entire Cache button. This is on a new site where I’m updating a theme fairly often. Without the ability to purge the cache after updating the theme, I have to login and manually remove the cache folder.

I verified the RT_WP_NGINX_HELPER_CACHE_PATH was set correctly and I believe the nginx config files are setup properly for fastcgi_cache_purge.

Thanks!


#11

I don’t think the issue was fixed. This plugin “Nginx Cache” appears to work just fine, at least on a single site Wordpress install. However I couldn’t get the old version working either so it could just be my configuraiton. Nginx Cache Just Worked.


#12

I had this problem on CentOS 7, and it seemed to be an SElinx issue. I had to run

sudo chcon -t httpd_sys_rw_content_t /etc/nginx/cache -R

to give the php-fpm process permission to write and delete the cache files.


#13

Any idea of the equivalent on Ubuntu?


#14

I have the same problem. Any solution?


#15