Nginx-helper and redis caching configuration


#1

I’m experiencing some behavior that doesn’t seem consistent and seems to be an issue with caching or how it’s configured. I will provide some details below that may be relevant.

I created my WordPress site with --wpredis option. I also updated to use php7.

I noticed recently that my test posts were only showing up if I was logged in to my WordPress site.

If I “flush cache” using the Redis Object Cache plugin settings the post will appear. I looked at the nginx-helper settings to ensure the purging was enabled, Redis-Cache was selected and the appropiate purge conditions were selected.

My configuration file in/etc/nginx/sites-available/ looks like this server {

    server_name mysite.com   www.mysite.com;


    access_log /var/log/nginx/mysite.com.access.log rt_cache_redis;
    error_log /var/log/nginx/mysite.com.error.log;


    root /var/www/mysite.com/htdocs;



    index index.php index.html index.htm;


    include  common/redis-php7.conf;

    include common/wpcommon-php7.conf;
    include common/locations-php7.conf;
    include /var/www/mysite.com/conf/nginx/*.conf;
}

Which is very different from this config

The current Redis settings under nginx-helper are as follows:

Hostname: 127.0.0.1 Port: 6379 Prefix: nginx-cache:

The info log file for nginx-helper appears to show the correct purging activity

Does the Redis Object Cache plugin setting Key Prefix need to match the prefix under “Redis settings” for the nginx-helper plugin?

Any help with things I should check/confirm with configuration would be appreciated. I think I may be overlooking something simple.


#2

@derek - did you ever sort this out? I’m trying to figure out a similar issue.


#3

I did not… For now I’m just flushing the cache manually, but not a good long term solution.


#4