Nginx fastcgi_cache and W3TC not working properly, white screen


#1

Hi,

I was just wondering. I’ve a setup of nginx with fastcgi_cache, works well. As soon as I activate W3TC for database and object cache, then I run into issues. Basically, the first time I run a page (or after cache has been cleaned), it doesn’t work: it loads forever and I end up with a 500. Then the second time it works. Then it works until, I think, the cache expires according to the setting I have in my nginx conf file. Any idea what could be wrong? The conf are coming from rtcamp.

Let me know if you’re interesting in this issue and what you need. Thanks!


#2

Also, strangely, when I activate W3TC, my site is twice slower. With just fastcgi_cache and the Zend opcode it is very, very fast.


#3

W3-Total-Cache Settings with Nginx FastCGI cache

  
Page Cache – Disable  
Minify – Disable this unless you are 100% sure your theme/plugin will support it nicely. Automatic minification rarely works for us.  
Database Cache – Memcache  
Object Cache - Memcache  
Browser Cache – Disabled  
CDN – You can use any CDN. Origin Pull is recommended. Check CDN Setup Guides for details.  

#4

Hi Mitesh,

Yep, this is what I use. I only use W3TC for database cache and object cache with memcache. Object cache is the culprit here, but I’m not sure why yet.


#5

It’s a memcached issue but I can’t find why. All seems ok, but I keep getting 500 errors at the first load. I’ve switched to disk caching, but it ends up slower than not using W3TC at all! So I’ve disabled the plugin. I think I’m gonna keep it like this for now.


#6