Nginx config file


#1

Looked in the FAQ and documentation and couldn’t find the answer I’m looking for.

Wondering where the nginx config file is as I need to make some edits, specifically add some rewrite rules that exist on my current apache configuration and also to make sure permalinks work on the new server.

Thanks!


#2

Hi,
You can use following command to edit site specific configuration:

  
ee site edit example.com  

Note:
Your apache rewrite rules are not supported in Nginx configuration, you need to convert that apache specific rules to Nginx rules.


#3

Ok, cool.

Having a weird issue trying to edit that file. I chose Nano as the editor (which works fine on my Linode server when editing other files). But editing this configuration file isn’t working. Any time I click the arrow key on my keyboard it starts rewriting the config file. Pressing the down arrow key writes ^[OB and when I try to exit (using ctrl-x) it writes ^X.

Have to force quite Terminal to get out. Have tried twice and same result.

Do you think this is a problem with the easy engine install, since I can use Nano on other server documents?


#4

Have confirmed that I can use Nano outside of easy engine and it works fine. Only gives me this strange bug when working with easy engine files.


#5

Found the text files on the server, so I guess I don’t need to use the ee site edit command anyway.


#6

ee site edit command additionally checks if updated nginx config is correct. Then it reloads nginx if config is correct.


#7

Well, that would be a cool feature. Any ideas why trying to use keys or ctrl is writing those strange characters?


#8

same thing happen to me, anyway to fix?


#9

I ended up using SFTP to make the edit as I couldn’t figure out what the problem was.


#10

Hi peter1,

Instead nano, change your default editor to vim. It will reduce your overhead of using sftp.
To change your default editor follow this.

  
cd   
rm .selected_editor.  

Now enter ee site edit example.com it will ask to choose default editor and select vim.


#11

Hello @peter1 ,

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support ticket for now. Feel free to create a new support ticket if you have any queries further. :slight_smile:


#12