Nginx Cache suddenly stopped working


#1

Well, basically, I updated two plugins and removed one, after what I noticed that can’t disable maintenance mode. I decided to purge all the cache using the button in admin panel, it didn’t work, but it worked before. So I had to delete all the files in nginx-cache folder, and after that it stopped working for some reason. It stopped generating files in folder and I get MISS in Headers all the time.
That is a pretty strange behavior, because it worked, and worked well, I didn’t touch any configs or whatever.


#2

Haha. I got what was the problem.
I had deactivated Wordfence Security plugin and cache started working.
So, probably it prevents caching somehow.


#3

@kee_ross Thanks for posting solution to your own problem.

We haven’t used or tested http://wordpress.org/plugins/wordfence/ plugin ourself but I remember another user once complaing about it.

We might give wordfence a try someday. For now, I am marking this topic as resolved.

Please feel free to use forum again if you face any issues.


#4