New Linode + EE - phpmyadmin installation problem -


#1

UPDATE:

Not sure it is considered “solved”, but this advice solved it:

" sudo apt-get install composer -y cd /var/www/22222/htdocs/db/pma composer sudo chown www-data: * -R "

  1. Maybe it should be included in the ee installation script?
  2. Why is a lot easier than the instructions on composer’s site? :\

Hi

Been using EE for few months now, and everything’s ok. New Linode installation, now I get an error when trying to run phpmyadmin “File ./vendor/autoload.php missing or not readable. Most likely you did not run Composer to install library files.”

Seems like there is some new version requiring a different process?

Thanks


#2

Hello Treelicker, there is an error with phpmyadmin since few weeks. To install phpmyadmin properly, after using ee to create the folder, install composer :

cd ~/
curl -sS https://getcomposer.org/installer | php

mv composer.phar /usr/bin/composer

Then login as www-data : su - www-data and go into the phpmyadmin folder cd 22222/htdocs/db/pma finally run : composer update

It will update phpmyadmin dependencies and fix the issue.


#3

“Could not open input file: mv” Should be two different lines after the “php”


#4

Sorry the code is not properly formated on the forum. You can see it here : https://bin.vtbox.net/dagupuzaxi.bash


#5

@treelicker @virtubox this issue occurred since the latest PhpMyadmin doesn’t ship with all dependencies. So we need to install those manually. The official documentation is updated with latest information. check https://easyengine.io/tutorials/php/phpmyadmin/


#6