Need help with BPM FFMPEG Transcoder


#1

BPM FFMPEG Transcoder <-- i can't find the media settings tab where we need to put the url and port.

and also when i upload .mov it shows this error Error: -601, Message: File extension error., File: Video.MOV

please help.


#2

You can find the settings of BPM FFMPEG in the settings page of BuddyPress Media plugin.

About the error, I am looking into it right now. Will send you a fix as soon as possible.

Attachment Link(s):

http://rtcamp.com/wp-content/uploads/rtMedia/topics/23938/2012/12/bpm-ffmpeg-settings.png


#3

Sorry for the trouble caused.

The issue is with BuddyPress Media, the version number constant defined in it wasn't updated in the last two releases.

So it will work if you simply update this single line in the loader.php file of the BuddyPress Media plugin on line 15, just write 2.3.1 instead of 2.2.8 and the plugin will work just fine.

Or you can download the zip file from here.

It will be automatically be corrected in the new bug fix release of BuddyPress Media tomorrow.


#4

Its corrected in the BuddyPress 2.3.2, just update the plugin and it will work.


#5

one more thing. we have installed media-node successfully. but everytime we upload a video it shows nothing after the status bar is completed. is there a way for us to confirm if media-node is working properly? i tried converting .mov to .flv using ffmeg command in shell and it converted successfully so i know ffmeg is working but i just dont know how to confirm if media-node works as well. please help.


#6

You can check that from the terminal using this command:

curl http://localhost:1203/status  

You'll be able to see the current status of the Media Node from this.


#7

thank you for the quick response. when i use curl http://localhost:1203/status it works. it shows the status. however if i replace localhost with ip it says cant connect.. do you have an idea what causes this? we are planning to use a remote server for conversion that is why localhost wont work for us. we need it to work with ip or domain name.


#8

Well, the Media-Node binds internally by default, I mean, it won't be accessible from external network for security concerns as we've not included any authentication service in it. So if its accessible externally anyone will be able to use your server for media conversion abusing your resources. So it will be accessible only via localhost or 127.0.0.1

Still if you want to access it from external IP, you can change the settings in the ffmpeg_server.js file on line 19.

var transcoder_ip = '127.0.0.1';   

#9

please ignore my last question. i was able to make it run in ip. will test it now and will give you feedback later.


#10

thank you again for the quick response:

i tried uploading a video .mov and it converts to .mp4 but when i check the logs i see the following:

Processing sample.MOV ffmpeg -i ./queued/sample.MOV -loglevel quiet -r 24 -vcodec libx264 -vprofile high -preset slow -vf scale=640:480 -b:v 1500k -maxrate 100k -bufsize 200k -threads 1 -acodec libfaac -b:a 128k "./temp/sample.mp4" stdout: stderr: exec error: Error: Command failed: processing queue


#11

If the conversion is going on smoothly then you dont need to worry about it. Sometimes in nodejs exec gives incorrect response. But if is not been converted successfully then let us know and we'll debug it.


#12

its not converting correctly i think. because till now when you open the page with video it says Media still being processed...


#13

ok what i did to test the ffmeg is execute the command manually and i get this error: Unknown encoder 'libfaac'

do you have a guide on how to install libfaac in CentOS?


#14

Which version of centos are you using? We'll create shell script for centos as well for installing ffmpeg correctly. But this might take some time.


#15

CentOS 5 thank you very much.


#16

Continued on the MediaNode discussion on this thread


#17