Mysql upload problem


#1

I have a mysql database [database.sql.gz] in my Download folder on my laptop.

I am migrating a wordpress site. I am using LEMP 14.04 64 bit on digitalocean with ee installed.

I am able to login to phpmyadmin and want to import the database via phpmydmin but it fails.

Any help on this much appreciated as I am at a complete standstill until I can get this done.

-P

Loggng into phpmyadmin as root and importing dbase produces following:

Error

MySQL said: Documentation 1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '‘https://www.sooqm.com/CatAdv.aspx?CatId=1&amp’ at line 1


#2

Ok - I uploaded an uncompressed sql file (at just a tad over 100mb) and it uploaded/imported ok.

So problem solved.

P


#3

@pressman

Glad to know your problem solved


#4

Hi . . . well, my problem of uploading the uncompressed dbase is solved. However, I am stuck at getting it to connect with the wordpress site. My steps so far :

  1. Created 14.04 64 bit droplet at Digital Ocean
  2. Installed ee and the ee stack
  3. Edited /etc/easyengine/ee.conf to show db-name as true and db-user as true.
  4. Created wordpress site using this < ee site create example.com --wpfc >.
  5. When asked for the database name, user and password I entered same data that exists on the old site, ie the data that sits in the wp-config file.

My question is, what do I do next ? Is it . . .

A) Use phpmyadmin to import the old sql database into the newly created database (with the same name). If so, what do I do with the tables that already exist in the NEW database ? Delete them before I import the database, delete them after I import the database or leave them there ? or . . .

B) Create a new database with a new name, import the old database into it and then change its name to the database name created in step 5 whilst either deleting or renaming the database recently created by the ee site bulding process.

I hope this is clear. Any help given much appreciated.

Pressman


#5

Ok, well, LOL, just as with my previous post I managed to work out what I was doing wrong. I uploaded/imported the old database files to the new one, but I failed to take into account the I had set a different prefix to all the wp tables, not wp_ but xxt_. Changed wp-config to look for xxt_ tables and bingo, it works. However . . .

. . . there is an issue with Wordpress plugins. They are there, they work but I cannot update them or delete them via the dashboard. I assume this is maybe something to do with nginx as I did not have this issue prior when running on apache.

Any pointers as to how to fix this ?


#6

Hi @pressman

It’s been a long time, and we haven’t heard from you. It looks like your issue is resolved.

I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#7