Mysql server failing to start after apt-get install


#1

I recently tried installing some mailing solutions seen on this tutorial. But when I ran:

apt-get install postfix postfix-mysql dovecot-core dovecot-imapd dovecot-pop3d dovecot-lmtpd dovecot-mysql mysql-server dovecot-sieve dovecot-managesieved

on my existing Ubuntu 14.04 machine, running easyengine 3.0.5, the installation failed and now mysql fails to start:

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Running ps -ef | grep mysql:

root      2400  1577  0 16:36 pts/0    00:00:00 grep --color=auto mysql

The file mysqld is not present in /etc/init.d/mysqld. And when I try to reinstall mysql-server I get the error

Aborting downgrade from (at least) 5.6 to 5.5.

I have several very important databases on this VPS, so I’m afraid of messing to much with it and losing the data.

Does anyone have any idea on how to get mysql running once again?


#2

Fixed by reinstalling SQL Server


#3

@Luandro_Vieira,

We are glad to know that you fixed your issue.


#4

Hi @Luandro_Vieira

As the issue has been resolved, I am closing this support topic for now. Feel free to create a new support topic if you have any queries further. :slight_smile:


#5