MySQL remote setup error


#1

Hey there guys, long time no see. Well, as usual, I was doing my tests on some enviroment droplets. I got the error bellow when I was trying to add a test WordPress site:

/usr/local/lib/easyengine/modules/site/create/ee_mod_setup_database.sh: line 12: [: ==: unary operator expected
/usr/local/lib/easyengine/modules/site/create/ee_mod_setup_database.sh: line 27: [: ==: unary operator expected

Any resolve ? Also, any Redis news? I heard that its a little better with it. Some tutorials/advices ?


#2

Hi, We just tested on EasyEngine fresh server with Remote MySQL, Everything is working fine.

Following is my log

Executing service postfix restart, please wait...
Git commit on /etc/postfix/, please wait...
postfix successfully installed
Creating ee-mysql.net, please wait...
Creating symbolic link for ee-mysql.net
Creating htdocs & logs directory
Downloading WordPress, please wait...
Enter the MySQL database name [ee-mysql_net]: ee-mysql-remote 
Enter the MySQL database username [ee-mysql_net]: 
Enter the MySQL database password [hrWs2hrkCeOwU0j]: 
Enter the WordPress table prefix [wp_]: 
Setting up WordPress, please wait...
_
Updating WordPress permalink, please wait...
Installing Nginx Helper plugin, please wait...
Changing ownership of /var/www/ee-mysql.net, please wait...
Git commit on /etc/nginx/, please wait...
Executing service nginx reload, please wait...
HTTP authentication username: easyengine
HTTP authentication password: 4Qv1Mm3JiunT33A

WordPress Admin Username: gaurav
WordPress Admin Password: 12345

Successfully created new website: http://ee-mysql.net

Can you please share your ee.conf file?

cat /etc/easyengine/ee.conf

#3

Well weird! Now its working and I didn’t change any line. Thanks for the quick answer Gaurav


#4

Hello @alexblajan

I hope your query is resolved. I am closing this support topic for now.

Feel free to create a new support topic if you have any queries further. :slight_smile:


#5